summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-02 20:12:07 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-02 20:21:42 +0100
commit386e0b27d32e1112dca2ce08d7a300f6cd5f4f4d (patch)
treed59ed3e54f9f9c3afce6a3985885a2397c7663cd /media-video/orion
parentmedia-gfx/hugin: drop redundant longdescription from metadata (diff)
downloadgentoo-386e0b27d32e1112dca2ce08d7a300f6cd5f4f4d.tar.gz
gentoo-386e0b27d32e1112dca2ce08d7a300f6cd5f4f4d.tar.bz2
gentoo-386e0b27d32e1112dca2ce08d7a300f6cd5f4f4d.zip
media-video/orion: 1.6.7 bump
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-video/orion')
-rw-r--r--media-video/orion/Manifest1
-rw-r--r--media-video/orion/orion-1.6.7.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-video/orion/Manifest b/media-video/orion/Manifest
index 1f95240e396b..74e67d47391a 100644
--- a/media-video/orion/Manifest
+++ b/media-video/orion/Manifest
@@ -1 +1,2 @@
DIST orion-1.6.6.tar.gz 629917 BLAKE2B 303af947533aeb26561fb3fc57d4ffbbd6d168e1e51ffe196a0de82fca3406599cfb84c1ae361c9b7b84c9c01b47bb6147b98f62cc5b1dec3d08d0588cbc7327 SHA512 88c7efe1796d1135f18bd53c83a25747df1bbf35163b27c625711ab5027e988425e3ba13ff6e3349d30cdc99d24cae0642d1d058e401a24b240d73c6b47a2aaf
+DIST orion-1.6.7.tar.gz 644899 BLAKE2B 7aa188bc5eaf1f1781735416152a9324a2945f10b2c1ccd55fa5a2b557c31e4bdad55d282c4efc0552dbf998db7193bc19ec0679034ec53cbd97f688b572f74c SHA512 dc4c4d364423cae52f95c4ad2d241e311d6947066c2a7b02b5754df2b69a7bb7aeed54d4515afe31b4437b8e47057e939e9444e7812ca0125ba3a8c65678d3d0
diff --git a/media-video/orion/orion-1.6.7.ebuild b/media-video/orion/orion-1.6.7.ebuild
new file mode 100644
index 000000000000..406bf1c592ec
--- /dev/null
+++ b/media-video/orion/orion-1.6.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="Cross-platform Twitch client"
+HOMEPAGE="https://alamminsalo.github.io/orion/"
+SRC_URI="https://github.com/alamminsalo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mpv qtav qtmedia"
+
+DEPEND=">=dev-qt/qtquickcontrols-5.8:5
+ >=dev-qt/qtquickcontrols2-5.8:5
+ >=dev-qt/qtsvg-5.8:5
+ >=dev-qt/qtwebengine-5.8:5
+ mpv? ( media-video/mpv[libmpv] )
+ qtav? ( media-libs/qtav )
+ qtmedia? ( >=dev-qt/qtmultimedia-5.8:5 )"
+RDEPEND="${DEPEND}
+ !mpv? ( media-plugins/gst-plugins-hls )"
+
+REQUIRED_USE="^^ ( mpv qtav qtmedia )"
+
+src_configure() {
+ local PLAYER
+ if use mpv; then
+ PLAYER=mpv
+ elif use qtav; then
+ PLAYER=qtav
+ else
+ PLAYER=multimedia
+ fi
+ eqmake5 ${PN}.pro CONFIG+=${PLAYER}
+}
+
+src_install() {
+ dobin ${PN}
+ domenu distfiles/*.desktop
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins distfiles/${PN}.svg
+}