summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/oxine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/oxine')
-rw-r--r--media-video/oxine/Manifest1
-rw-r--r--media-video/oxine/metadata.xml11
-rw-r--r--media-video/oxine/oxine-0.7.1-r1.ebuild67
3 files changed, 79 insertions, 0 deletions
diff --git a/media-video/oxine/Manifest b/media-video/oxine/Manifest
new file mode 100644
index 000000000000..d0cedfcc1d69
--- /dev/null
+++ b/media-video/oxine/Manifest
@@ -0,0 +1 @@
+DIST oxine-0.7.1.tar.gz 3653511 SHA256 bfe9e4f49996234eabf788397969c90901197b2b1823cdb9a61e529f5c0f6a7d SHA512 96f6851f6277d97530b1f4d95d0f0843c9c3262d1a97ccc431e8a674441e06ca8fc24a65f83be5735f54e089d636e60fb297fa7958279b24004eecbc1711a257 WHIRLPOOL 6e8c91ceb889dfa97daaa6f291987d0becb622c6755f82d01d9489016aa2699c0de1b499e274c0129fd440b821b840e05f7c3a2c7a9ed9539a2c13b230f00880
diff --git a/media-video/oxine/metadata.xml b/media-video/oxine/metadata.xml
new file mode 100644
index 000000000000..3df2181b12a2
--- /dev/null
+++ b/media-video/oxine/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">oxine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/oxine/oxine-0.7.1-r1.ebuild b/media-video/oxine/oxine-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..56824339afa7
--- /dev/null
+++ b/media-video/oxine/oxine-0.7.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+WANT_AUTOMAKE="1.9"
+inherit eutils
+
+DESCRIPTION="OSD frontend for Xine"
+HOMEPAGE="http://oxine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+SLOT="0"
+IUSE="X curl debug dvb exif joystick jpeg lirc nls png v4l"
+
+COMMON_DEPEND="media-libs/xine-lib[v4l?,X,imagemagick]
+ dvb? ( media-libs/xine-lib[v4l] )
+ dev-libs/libcdio
+ curl? ( net-misc/curl )
+ joystick? ( media-libs/libjsw )
+ jpeg? ( media-gfx/imagemagick
+ media-libs/netpbm[jpeg,zlib]
+ media-video/mjpegtools )
+ lirc? ( app-misc/lirc )
+ nls? ( virtual/libintl
+ sys-devel/gettext )
+ png? ( media-gfx/imagemagick
+ media-libs/netpbm[png,zlib]
+ media-video/mjpegtools )
+ X? ( x11-libs/libXext
+ x11-libs/libX11 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/eject"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # Note on images: Image support will be automatically disabled if
+ # netpbm, imagemagick or mjpegtools is not installed, irregardless
+ # of what the USE flags are set to.
+
+ # If one of the image USE flags is unset, disable image support
+ if use !png && use !jpeg ; then
+ myconf="${myconf} --disable-images"
+ fi
+
+ econf ${myconf} \
+ $( use_with X x ) \
+ $( use_with curl ) \
+ $( use_enable debug ) \
+ $( use_enable dvb ) \
+ $( use_enable exif ) \
+ --disable-hal \
+ $( use_enable joystick ) \
+ $( use_enable lirc ) \
+ $( use_enable nls ) \
+ $( use_enable v4l ) \
+ --disable-extractor \
+ --disable-rpath || die "econf died"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install died"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml doc/README.html doc/keymapping.pdf
+}