summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-27 14:19:02 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-27 14:19:02 +0200
commit4fca59458fe57cb91690293751b04e2d746f85e7 (patch)
treee6381a051d17bb71e826bdac8728604291068511 /media-video/parole
parentdev-util/catfish: Bump to 1.4.8 (diff)
downloadgentoo-4fca59458fe57cb91690293751b04e2d746f85e7.tar.gz
gentoo-4fca59458fe57cb91690293751b04e2d746f85e7.tar.bz2
gentoo-4fca59458fe57cb91690293751b04e2d746f85e7.zip
media-video/parole: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-video/parole')
-rw-r--r--media-video/parole/Manifest1
-rw-r--r--media-video/parole/parole-1.0.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-video/parole/Manifest b/media-video/parole/Manifest
index 9d3a1668d864..43c44a9479a0 100644
--- a/media-video/parole/Manifest
+++ b/media-video/parole/Manifest
@@ -1 +1,2 @@
DIST parole-1.0.2.tar.bz2 915511 BLAKE2B e6fa116cae5c015a90b4a1d04df70f006ad59dfdb5d849b8ae8c3fdc0665e48790739c82bdb7c35c70f34548b9bee3dcac62f29e28562663d46b10a3a080f13d SHA512 d7e989af7f9dab14080e62bd656a2858d8536a056ba82b5d5ac7d26a7d898f478b74c1ba4371779624691b7f42b695580ad53cfb15da0a4dc209d7570c12a66d
+DIST parole-1.0.3.tar.bz2 963822 BLAKE2B 8f7131ea8e46541edab093514f7955ebe551549f1e6057186b87d2e5074a9760eb571b36c65cb7d33ff398432c2397fca3ffc764fb924967b50343eb4d7e93a9 SHA512 6163cd9d37b50093a44694af79aa421e9cd33ba92b2cf3e15640894fe9c51809ed7e93a31eccd274cfd9934fb34a63e6a21a161f5a0a96aeb20faac85ff65d16
diff --git a/media-video/parole/parole-1.0.3.ebuild b/media-video/parole/parole-1.0.3.ebuild
new file mode 100644
index 000000000000..f14dfea94f96
--- /dev/null
+++ b/media-video/parole/parole-1.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="A simple Xfce4 media player using GStreamer"
+HOMEPAGE="https://docs.xfce.org/apps/parole/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="libnotify taglib"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
+ >=dev-libs/glib-2.32:2=
+ media-libs/gstreamer:1.0=
+ media-libs/gst-plugins-base:1.0=
+ sys-apps/dbus:0=
+ >=x11-libs/gtk+-3.20:3=
+ x11-libs/libX11:0=
+ >=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:0=
+ >=xfce-base/xfconf-4.10:0=
+ libnotify? ( >=x11-libs/libnotify-0.7:0= )
+ taglib? ( >=media-libs/taglib-1.6:0= )"
+RDEPEND="${COMMON_DEPEND}
+ media-plugins/gst-plugins-meta:1.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto"
+
+DOCS=( AUTHORS ChangeLog README THANKS TODO )
+
+src_configure() {
+ local myconf=(
+ # clutter backend does not work with new GTK+3 versions
+ --disable-clutter
+ $(use_enable taglib)
+ $(use_enable libnotify notify-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}