summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-03 23:06:18 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-04 00:47:15 +0200
commit4d682a60dc98853f315bfe0d857a95e1c7c4daad (patch)
treea7bebbd4ba1e541f3a76c4afa77a72bb96363069 /media-video/pitivi
parentnet-misc/networkmanager-fortisslvpn: version bump 1.2.2 → 1.2.4 (diff)
downloadgentoo-4d682a60dc98853f315bfe0d857a95e1c7c4daad.tar.gz
gentoo-4d682a60dc98853f315bfe0d857a95e1c7c4daad.tar.bz2
gentoo-4d682a60dc98853f315bfe0d857a95e1c7c4daad.zip
media-video/pitivi: version bump 0.97.1 → 0.98.1, bug #606850
Add missing dependency on gdkpixbuf plugin, bug #628608. Closes: https://bugs.gentoo.org/show_bug.cgi?id=606850 Closes: https://bugs.gentoo.org/show_bug.cgi?id=628608 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/Manifest1
-rw-r--r--media-video/pitivi/files/pitivi-0.98.1-optional-tests.patch23
-rw-r--r--media-video/pitivi/pitivi-0.98.1.ebuild94
3 files changed, 118 insertions, 0 deletions
diff --git a/media-video/pitivi/Manifest b/media-video/pitivi/Manifest
index 8cefd74ba89f..3c91e84d740c 100644
--- a/media-video/pitivi/Manifest
+++ b/media-video/pitivi/Manifest
@@ -1 +1,2 @@
DIST pitivi-0.97.1.tar.xz 5096672 SHA256 41b23cfd21353647e55a0b2e86bab368b61d6f1a76cc132e80ca0dd27f000e77 SHA512 be5fcf5148349f685f0ee23a82b36d90fe0b7ff6d1d8cdcaf73272b8e5c29ddfe1d6c21353eb95f2d786fe4922a93c747403e5e27141d815f5b46f846a1d95ba WHIRLPOOL dae38565e8665abdf4eacb76ecc87530f2a429266572bbd5db3138e31fa1ae949dafb077dcfffb75fe094c3b55839fba2259690aa5faa1258647b546f661e2e0
+DIST pitivi-0.98.1.tar.xz 5112280 SHA256 10a8e23600681af5f7aed0412400d48e5b5e0fbfb609658ff2c636010f27f32d SHA512 b6530b1b5429c4379699d7492c31ec60ddc514c94a003fe240f7e390b6349093d2f4f72abb1edb4253bd938620c73dfb361abf21915d36ff3b75332e8612bcb3 WHIRLPOOL 4ad31d1499ba2dd7c880f7ba4728439535f2f6dc4bfcdfa58992e48f4d7456f87e31107382935bbea22c9b105f5a4df32bfbab218eab41809b3c008e02e42ae3
diff --git a/media-video/pitivi/files/pitivi-0.98.1-optional-tests.patch b/media-video/pitivi/files/pitivi-0.98.1-optional-tests.patch
new file mode 100644
index 000000000000..e5f55ffe765f
--- /dev/null
+++ b/media-video/pitivi/files/pitivi-0.98.1-optional-tests.patch
@@ -0,0 +1,23 @@
+Make tests optional
+
+--- a/meson_options.txt 2016-09-19 23:35:54.944511834 +0200
++++ b/meson_options.txt 2016-09-19 23:36:10.693485976 +0200
+@@ -1,2 +1,3 @@
+ option('enable-xunit', type : 'boolean', value : false)
+ option('disable-help', type : 'boolean', value : false)
++option('enable-tests', type : 'boolean', value : false)
+--- a/meson.build 2017-09-03 22:52:39.681974053 +0200
++++ b/meson.build 2017-09-03 22:53:29.934556188 +0200
+@@ -71,8 +71,10 @@
+ if not get_option('disable-help')
+ subdir('help')
+ endif
+-subdir('tests')
+-subdir('tests/validate-tests')
++if get_option('enable-tests')
++ subdir('tests')
++ subdir('tests/validate-tests')
++endif
+
+ archiver = find_program('git-archive-all', required : false)
+ if archiver.found()
diff --git a/media-video/pitivi/pitivi-0.98.1.ebuild b/media-video/pitivi/pitivi-0.98.1.ebuild
new file mode 100644
index 000000000000..99a1d08352ec
--- /dev/null
+++ b/media-video/pitivi/pitivi-0.98.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit gnome.org meson python-single-r1 virtualx
+
+DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
+HOMEPAGE="http://www.pitivi.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="v4l test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# XXX: recommends gst-plugins-libav and frei0r-plugins
+
+# Do not forget to check pitivi/check.py for dependencies!!!
+# pycanberra, libav, libnotify and liwnck are optional
+GST_VER="1.10.2"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pycairo-1.10[${PYTHON_USEDEP}]
+ >=x11-libs/cairo-1.10
+
+ >=media-libs/gstreamer-${GST_VER}:1.0[introspection]
+ >=media-plugins/gst-transcoder-1.8.2-r1
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/glib-2.30.0:2
+
+ >=dev-libs/gobject-introspection-1.34:=
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-1.4:1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pycanberra[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+
+ gnome-base/librsvg:=
+
+ >=media-libs/gstreamer-editing-services-${GST_VER}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${GST_VER}:1.0[introspection]
+ >=media-libs/gst-plugins-bad-${GST_VER}:1.0[gtk]
+ >=media-libs/gst-plugins-good-${GST_VER}:1.0
+ >=media-plugins/gst-plugins-libav-${GST_VER}:1.0
+ >=media-plugins/gst-plugins-gdkpixbuf-${GST_VER}:1.0
+
+ x11-libs/libnotify[introspection]
+ x11-libs/libwnck:3[introspection]
+ >=x11-libs/gtk+-3.20.0:3[introspection]
+
+ v4l? ( >=media-plugins/gst-plugins-v4l2-${GST_VER}:1.0 )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-python/setuptools
+ >=dev-util/intltool-0.35.5
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-python/nose2[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ # Make tests optional, bug #594096
+ "${FILESDIR}"/${P}-optional-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Denable-tests=$(usex test true false)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_test() {
+ export PITIVI_TOP_LEVEL_DIR="${S}"
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"
+}