summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/qt-recordmydesktop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/qt-recordmydesktop')
-rw-r--r--media-video/qt-recordmydesktop/Manifest1
-rw-r--r--media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-check-for-jack.patch32
-rw-r--r--media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-desktopfile.patch18
-rw-r--r--media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-pyqt4.patch14
-rw-r--r--media-video/qt-recordmydesktop/metadata.xml9
-rw-r--r--media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild59
6 files changed, 133 insertions, 0 deletions
diff --git a/media-video/qt-recordmydesktop/Manifest b/media-video/qt-recordmydesktop/Manifest
new file mode 100644
index 000000000000..0bf9176e0294
--- /dev/null
+++ b/media-video/qt-recordmydesktop/Manifest
@@ -0,0 +1 @@
+DIST qt-recordmydesktop-0.3.8.tar.gz 185528 SHA256 84e43332ea1974edd8da3edb67456e57a40d3083a23c8d19d8f76b098a226f61
diff --git a/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-check-for-jack.patch b/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-check-for-jack.patch
new file mode 100644
index 000000000000..08c1b7484916
--- /dev/null
+++ b/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-check-for-jack.patch
@@ -0,0 +1,32 @@
+--- src/rmdPrefsWidget.py.orig 2008-11-23 16:09:14.000000000 +0100
++++ src/rmdPrefsWidget.py 2010-05-24 16:23:30.255865721 +0200
+@@ -302,9 +302,29 @@
+ def remPort(self,lwi):
+ self.jack_lsp_listSave.takeItem(self.jack_lsp_listSave.row(lwi))
+
++ def which(self,program):
++ import os
++ def is_exe(fpath):
++ return os.path.exists(fpath) and os.access(fpath, os.X_OK)
++
++ fpath, fname = os.path.split(program)
++ if fpath:
++ if is_exe(program):
++ return program
++ else:
++ for path in os.environ["PATH"].split(os.pathsep):
++ exe_file = os.path.join(path, program)
++ if is_exe(exe_file):
++ return exe_file
++
++ return None
++
+ def __runJackLSP__(self,button=None):
+ self.ports=[]
+ failed=0
++ if self.which('jack_lsp') == None:
++ self.jack_button.setEnabled(False)
++ return
+ (stdin,stdout,stderr)=os.popen3(['jack_lsp'],'t')
+ ports=stdout.readlines()
+ stdin.close()
diff --git a/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-desktopfile.patch b/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-desktopfile.patch
new file mode 100644
index 000000000000..77d5618a765d
--- /dev/null
+++ b/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-desktopfile.patch
@@ -0,0 +1,18 @@
+Fixes errors reported by desktop-file-validate.
+
+--- src/qt-recordmydesktop.desktop
++++ src/qt-recordmydesktop.desktop
+@@ -1,12 +1,11 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+ Name=qt-recordMyDesktop
+ Comment=Frontend for recordMyDesktop
+ Comment[fr]=Interface pour recordmydesktop
+ Exec=qt-recordMyDesktop
+ Terminal=false
+ Type=Application
+-Icon=qt-recordmydesktop.png
++Icon=qt-recordmydesktop
+ Categories=AudioVideo;Recorder;
+ StartupNotify=false
diff --git a/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-pyqt4.patch b/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-pyqt4.patch
new file mode 100644
index 000000000000..9b2368cfd660
--- /dev/null
+++ b/media-video/qt-recordmydesktop/files/qt-recordmydesktop-0.3.8-pyqt4.patch
@@ -0,0 +1,14 @@
+Index: qt-recordmydesktop-0.3.8/configure.ac
+===================================================================
+--- qt-recordmydesktop-0.3.8.orig/configure.ac
++++ qt-recordmydesktop-0.3.8/configure.ac
+@@ -50,8 +50,7 @@ fi
+ b=$(echo "$PYQT4_VERSION" | awk 'BEGIN{ FS="." } { print $1 "\n" $2 "\n" $3 }')
+ c=($b)
+
+-
+-export PYQT4_MAJOR=${c[[0]]}
++export PYQT4_MAJOR=${c[[0]]/snapshot-/}
+ export PYQT4_MINOR=${c[[1]]}
+
+ if test $PYQT4_MAJOR != 4; then
diff --git a/media-video/qt-recordmydesktop/metadata.xml b/media-video/qt-recordmydesktop/metadata.xml
new file mode 100644
index 000000000000..2f0746fb146b
--- /dev/null
+++ b/media-video/qt-recordmydesktop/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="sourceforge">recordmydesktop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild b/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild
new file mode 100644
index 000000000000..ac6dc491d57d
--- /dev/null
+++ b/media-video/qt-recordmydesktop/qt-recordmydesktop-0.3.8-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+inherit autotools base eutils python
+
+DESCRIPTION="Qt4 interface for RecordMyDesktop"
+HOMEPAGE="http://recordmydesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/recordmydesktop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# Test is buggy : bug #186752
+# Tries to run intl-toolupdate without it being substituted from
+# configure, make test tries run make check in flumotion/test what
+# makes me think that this file has been copied from flumotion without
+# much care...
+RESTRICT="test"
+
+RDEPEND=">=media-video/recordmydesktop-0.3.8
+ x11-apps/xwininfo"
+DEPEND="${RDEPEND}
+ >=dev-python/PyQt4-4.1[X]"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-check-for-jack.patch"
+ "${FILESDIR}/${P}-desktopfile.patch"
+ "${FILESDIR}/${P}-pyqt4.patch"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+
+ # these deps are required by PyQt4, not this package
+ sed -e '/^PKG_CHECK_MODULES/d' -i configure.ac || die "sed failed"
+ eautoreconf
+
+ python_convert_shebangs 2 src/qt-recordMyDesktop.in
+
+ sed -e 's/@ALL_LINGUAS@//' -i po/Makefile.in.in \
+ || die "respect linguas sed failed"
+ strip-linguas -i po
+ echo ${LINGUAS} | tr ' ' '\n' > po/LINGUAS
+}