summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-08-24 16:11:23 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-08-24 16:11:42 +0900
commit072832ee7e42b6939b2374827b4b22679e8fe0e3 (patch)
tree16fecd5e39f20bb6b679bfea848d9451d0094e3e /media-video/rtmpdump/rtmpdump-9999.ebuild
parentdev-python/paramiko: keyworded 2.2.1 for ia64, bug #628670 (diff)
downloadgentoo-072832ee7e42b6939b2374827b4b22679e8fe0e3.tar.gz
gentoo-072832ee7e42b6939b2374827b4b22679e8fe0e3.tar.bz2
gentoo-072832ee7e42b6939b2374827b4b22679e8fe0e3.zip
media-video/rtmpdump: fix librtmp pkg-config paths for Prefix.
Bump -9999 to EAPI 6 and git-r3 as a side effect. Bug: 616202 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-video/rtmpdump/rtmpdump-9999.ebuild')
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index b4c247a6697e..80f3d75437d5 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="6"
-inherit git-2 multilib toolchain-funcs multilib-minimal flag-o-matic
+inherit git-r3 multilib toolchain-funcs multilib-minimal flag-o-matic
DESCRIPTION="RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
@@ -40,6 +40,7 @@ src_prepare() {
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
+ eapply_user
multilib_copy_sources
}
@@ -69,6 +70,6 @@ multilib_src_install() {
else
cd librtmp || die
fi
- emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir='$(prefix)/share/man' \
CRYPTO="${crypto}" install
}