summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorreagentoo <reagentoo@gmail.com>2018-01-03 13:46:40 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-01-04 20:58:58 +0300
commit937439cecd19db5bc8e497c5218c2d59b622094b (patch)
treed8575a3b8e91f74d2b516c2b81f75e70512cb8f9 /media-video/shotcut
parentapp-portage/unsymlink-lib: Bump to v9 (diff)
downloadgentoo-937439cecd19db5bc8e497c5218c2d59b622094b.tar.gz
gentoo-937439cecd19db5bc8e497c5218c2d59b622094b.tar.bz2
gentoo-937439cecd19db5bc8e497c5218c2d59b622094b.zip
media-video/shotcut: new package
Closes: https://github.com/gentoo/gentoo/pull/6729
Diffstat (limited to 'media-video/shotcut')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/metadata.xml15
-rw-r--r--media-video/shotcut/shotcut-18.01.ebuild64
3 files changed, 80 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
new file mode 100644
index 000000000000..740971e5142a
--- /dev/null
+++ b/media-video/shotcut/Manifest
@@ -0,0 +1 @@
+DIST shotcut-18.01.tar.gz 4027948 BLAKE2B cbc82eac35b3d378bd0da6857f80fddf758e17d82d5be25224716769d51afc9a37ecd5395f0599fc421d6190d6a426ad2f9ab222fb3871f9e5e07b11465d38a4 SHA512 d36843eeb6f2906f3b9f546b24e691754984897bda74618ebebd85bb7e32f97d951d55bc6dcf6f2b0f1c1ab39ee1180de5b44e7022ee2fe9b687e3cb4b9bada3
diff --git a/media-video/shotcut/metadata.xml b/media-video/shotcut/metadata.xml
new file mode 100644
index 000000000000..9fca7f80ebad
--- /dev/null
+++ b/media-video/shotcut/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>reagentoo@gmail.com</email>
+ <name>Dmitry Baranov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mltframework/shotcut</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/shotcut/shotcut-18.01.ebuild b/media-video/shotcut/shotcut-18.01.ebuild
new file mode 100644
index 000000000000..3367892ca51e
--- /dev/null
+++ b/media-video/shotcut/shotcut-18.01.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop qmake-utils
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/"
+SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/ladspa-sdk
+ media-libs/libsdl:0
+ media-libs/libvpx
+ media-libs/mlt[ffmpeg,frei0r,qt5,sdl,xml]
+ media-libs/x264
+ media-plugins/frei0r-plugins
+ media-sound/lame
+ media-video/ffmpeg
+ virtual/jack
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_prepare() {
+ local mylrelease="$(qt5_get_bindir)/lrelease"
+ "${mylrelease}" "${S}/src/src.pro" || die "preparing locales failed"
+
+ default
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ newicon "${S}/icons/shotcut-logo-64.png" "${PN}.png"
+ make_desktop_entry shotcut "Shotcut"
+
+ insinto "/usr/share/${PN}/translations"
+ doins translations/*.qm
+
+ einstalldocs
+}