summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/snappy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/snappy')
-rw-r--r--media-video/snappy/Manifest1
-rw-r--r--media-video/snappy/metadata.xml8
-rw-r--r--media-video/snappy/snappy-1.0.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/media-video/snappy/Manifest b/media-video/snappy/Manifest
new file mode 100644
index 000000000000..864debe9d105
--- /dev/null
+++ b/media-video/snappy/Manifest
@@ -0,0 +1 @@
+DIST snappy-1.0.tar.xz 282964 SHA256 0d33a05c1ad3cc075b8b9bf38d45634ea5204159454597b0882dd6a8d9763f58 SHA512 d8a3fd3a598efde4d699cc8fa13bee1239917a877627b26d5d278af5fd1824f02acf5ce685f8bf994087b3374de9917a5aa4f6f6ebe94f385c8d3bf91887eca9 WHIRLPOOL 0dd3b30e6208b37af4e8476604c80718a1939481bb105f54338559f952f1cf78d5110b0dde8ba389a8bfe065a268ef6595b308a5c38289ae0f4b76c684969340
diff --git a/media-video/snappy/metadata.xml b/media-video/snappy/metadata.xml
new file mode 100644
index 000000000000..8343b79cd5dc
--- /dev/null
+++ b/media-video/snappy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gstreamer</herd>
+ <longdescription lang="en">
+ Snappy is a gstreamer + clutter media player with powerful features in mind
+ </longdescription>
+</pkgmetadata>
diff --git a/media-video/snappy/snappy-1.0.ebuild b/media-video/snappy/snappy-1.0.ebuild
new file mode 100644
index 000000000000..718e80519469
--- /dev/null
+++ b/media-video/snappy/snappy-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A simple media player written using GStreamer and Clutter"
+HOMEPAGE="https://wiki.gnome.org/Apps/Snappy"
+
+KEYWORDS="amd64 x86"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gst-2.0.0:2.0
+ >=media-libs/clutter-gtk-1.0.2:1.0
+ >=x11-libs/gtk+-3.5.0:3
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.0.0:1.0
+ >=media-libs/gst-plugins-base-1.0.0:1.0
+
+ media-plugins/gst-plugins-meta:1.0
+
+ !!net-misc/spice-gtk
+" # FIXME: File collision -- /usr/bin/snappy
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ DOCS="AUTHORS README THANKS ToDo docs/*"
+ gnome2_src_configure --enable-dbus
+}