summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/sonic-snap/sonic-snap-1.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/sonic-snap/sonic-snap-1.7.ebuild')
-rw-r--r--media-video/sonic-snap/sonic-snap-1.7.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-video/sonic-snap/sonic-snap-1.7.ebuild b/media-video/sonic-snap/sonic-snap-1.7.ebuild
new file mode 100644
index 000000000000..d74317962bec
--- /dev/null
+++ b/media-video/sonic-snap/sonic-snap-1.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit eutils linux-info multilib toolchain-funcs
+
+DESCRIPTION="Webcam app for sn9c10x based camera controllers (with optional MPEG4 support)"
+HOMEPAGE="http://www.stolk.org/sonic-snap/"
+SRC_URI="http://www.stolk.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mpeg"
+
+DEPEND="x11-libs/fltk:1
+ mpeg? ( >=media-libs/libfame-0.9.1 )
+ sys-libs/zlib
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft"
+
+CONFIG_CHECK="~USB_SN9C102"
+ERROR_USB_SN9C102="Please make sure the SN9C1xx PC Camera Controller driver is \
+enabled, under V4L USB devices, as a module in your kernel."
+
+src_prepare() {
+ # fix bad assumptions
+ sed -i \
+ -e "s|\$(HOME)/include|/usr/include|" \
+ -e "s|\$(HOME)/lib|/usr/$(get_libdir)|" \
+ -e "s|CFLAGS=|CFLAGS= ${CXXFLAGS} |" \
+ -e "s|LFLAGS=|LFLAGS= ${LDFLAGS} |" \
+ -e "s/g++-4.0 -O3/$(tc-getCXX)/" \
+ Makefile
+
+ use mpeg || sed -i -e "s?USE_FAME=1?USE_FAME=0?g" Makefile
+}
+
+src_compile() {
+ make || die '"make" failed.'
+}
+
+src_install() {
+ dodir /usr/bin
+ make DESTDIR="${D}" install || die '"make install" failed.'
+
+ dodoc ChangeLog README
+ doman debian/sonic-snap.1
+}
+
+pkg_postinst() {
+
+ elog
+ elog "This driver is V4L v2 only, so V4L v1 apps will not work."
+ elog "Finally, only a few image sensors are supported, eg, PAS106B"
+ elog "so (check dmesg or /var/log/messages for USB device info when"
+ elog "you plug the cam in)."
+ elog
+ elog "Now try sonic-snap-gui /dev/videoX (where X is 0, 1 , etc)."
+ elog
+}