summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-05-11 22:13:15 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-06-01 11:41:46 +0300
commit67491056177628c17bbfd42349fe5a75d8b59d2d (patch)
tree36b6b023e4370a5f865c5d7b9f765a6dc46f3a2b /media-video/subliminal
parentapp-forensics/zzuf: make static-libs optional (diff)
downloadgentoo-67491056177628c17bbfd42349fe5a75d8b59d2d.tar.gz
gentoo-67491056177628c17bbfd42349fe5a75d8b59d2d.tar.bz2
gentoo-67491056177628c17bbfd42349fe5a75d8b59d2d.zip
media-video/subliminal: Bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/subliminal')
-rw-r--r--media-video/subliminal/Manifest1
-rw-r--r--media-video/subliminal/files/subliminal-2.1.0-fix-pytest-warning.patch11
-rw-r--r--media-video/subliminal/subliminal-2.1.0.ebuild83
3 files changed, 95 insertions, 0 deletions
diff --git a/media-video/subliminal/Manifest b/media-video/subliminal/Manifest
index 9a2ec3049437..df7a19ff8ab3 100644
--- a/media-video/subliminal/Manifest
+++ b/media-video/subliminal/Manifest
@@ -1,2 +1,3 @@
DIST matroska_test_w1_1.zip 184550509 BLAKE2B f111725aa08267661942072c2d4ac019d3d322c4e933aad10afb3aa6f69bb3469114c4400d161e53d8a7618b818b22465177460003804a7ac3e69fa4f4db000d SHA512 f170a8e83dab15228f992b3692330163da2402b8e436c7fa195ac1ecc06cf1eaf1a48d8c99a85c031122c158c2d4006023aae75d5b7805385ba25a6d601cb78f
DIST subliminal-2.0.5-r2.tar.gz 4442435 BLAKE2B ea2139bd61344d6a0cb4b48a2b75cbfd29905adc81bca25a332443725fff80bc03b58704d0e6289d44ddc26104e15744f67acb7e0e4eafae584098b02fb4c007 SHA512 b0f99c6b2fa6bc3860c86592bb428c7b4b34836df7a619b19d69b15532a68b4d05369f724131e120d4b390bd91f430aea442aef72ebc00ae8e3d31a457925eec
+DIST subliminal-2.1.0.tar.gz 5480458 BLAKE2B 249bdd027d99dfb0b81d939af2dc08f62b52dca2c8618f1006ca76eee41c2443b450076eddc1aa533997beca8cdf9016b884d7eceeebbf4e48ced91dae1a2361 SHA512 9b26ae594895470830547eed604aa5b28b75f590e5be12c2d5a478c5daf798d405f209639bd54dce0565b0e27d1b0daa5bef87dfa8590af61f2ab1e287c41060
diff --git a/media-video/subliminal/files/subliminal-2.1.0-fix-pytest-warning.patch b/media-video/subliminal/files/subliminal-2.1.0-fix-pytest-warning.patch
new file mode 100644
index 000000000000..b3d6cd019fda
--- /dev/null
+++ b/media-video/subliminal/files/subliminal-2.1.0-fix-pytest-warning.patch
@@ -0,0 +1,11 @@
+diff --git a/pytest.ini b/pytest.ini
+index cfa3e35..e85c34b 100644
+--- a/pytest.ini
++++ b/pytest.ini
+@@ -9,3 +9,6 @@ flakes-ignore =
+ docs/conf.py ALL
+ subliminal/__init__.py UnusedImport
+ doctest_optionflags = NORMALIZE_WHITESPACE IGNORE_EXCEPTION_DETAIL
++markers =
++ integration
++ converter
diff --git a/media-video/subliminal/subliminal-2.1.0.ebuild b/media-video/subliminal/subliminal-2.1.0.ebuild
new file mode 100644
index 000000000000..bca1f740d389
--- /dev/null
+++ b/media-video/subliminal/subliminal-2.1.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE='xml(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.org/project/subliminal/"
+SRC_URI="
+ https://github.com/Diaoul/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.4.0:4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012c[${PYTHON_USEDEP}]
+ >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/unzip
+ dev-python/sympy[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pytest-warning.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable code checkers as they require unavailable dependencies.
+ sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ if use test; then
+ mkdir -p tests/data/mkv || die
+ ln -s "${WORKDIR}"/test*.mkv tests/data/mkv/ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ tests/test_core.py::test_scan_archive_with_one_video
+ tests/test_core.py::test_scan_archive_with_multiple_videos
+ tests/test_core.py::test_scan_archive_with_no_video
+ tests/test_core.py::test_scan_password_protected_archive
+ )
+
+ # Two tests that list providers rely on entry points
+ # so they need the package to be installed
+ distutils_install_for_testing
+ pytest -vv --ignore ${PN}/test/test_core.py ${skipped_tests[@]/#/--deselect } \
+ || die "Tests fail with ${EPYTHON}"
+}