summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/ushare/ushare-1.1a-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/ushare/ushare-1.1a-r5.ebuild')
-rw-r--r--media-video/ushare/ushare-1.1a-r5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-video/ushare/ushare-1.1a-r5.ebuild b/media-video/ushare/ushare-1.1a-r5.ebuild
new file mode 100644
index 000000000000..3c9ec8e55652
--- /dev/null
+++ b/media-video/ushare/ushare-1.1a-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib readme.gentoo toolchain-funcs user
+
+DESCRIPTION="uShare is a UPnP (TM) A/V & DLNA Media Server"
+HOMEPAGE="http://ushare.geexbox.org/"
+SRC_URI="http://ushare.geexbox.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dlna nls"
+
+RDEPEND=">=net-libs/libupnp-1.6.14
+ dlna? ( >=media-libs/libdlna-0.2.4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ EPATCH_SOURCE="${FILESDIR}" EPATCH_SUFFIX="patch" \
+ EPATCH_OPTS="-p1" epatch
+
+ DOC_CONTENTS="Please edit /etc/conf.d/ushare to set the shared directories
+ and other important settings. Check system log if ushare is
+ not booting."
+}
+
+src_configure() {
+ local myconf
+ myconf="--prefix=/usr --disable-sysconf --disable-strip $(use_enable dlna)"
+ # nls can only be disabled, on by default.
+ use nls || myconf="${myconf} --disable-nls"
+
+ # I can't use econf
+ # --host is not implemented in ./configure file
+ tc-export CC CXX
+
+ ./configure ${myconf} || die "./configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman src/ushare.1
+ newconfd "${FILESDIR}"/ushare.conf.d ushare
+ newinitd "${FILESDIR}"/ushare.init.d ushare
+ dodoc NEWS README TODO THANKS AUTHORS
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ enewuser ushare
+ readme.gentoo_print_elog
+}