summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/xanim-export/xanim-export-2.80.1-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/xanim-export/xanim-export-2.80.1-r5.ebuild')
-rw-r--r--media-video/xanim-export/xanim-export-2.80.1-r5.ebuild110
1 files changed, 110 insertions, 0 deletions
diff --git a/media-video/xanim-export/xanim-export-2.80.1-r5.ebuild b/media-video/xanim-export/xanim-export-2.80.1-r5.ebuild
new file mode 100644
index 000000000000..a5ef7ef5fa54
--- /dev/null
+++ b/media-video/xanim-export/xanim-export-2.80.1-r5.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic eutils toolchain-funcs
+
+_XA_CYUV_sparc=xa1.0_cyuv_sparcELF.o
+_XA_CVID_sparc=xa2.0_cvid_sparcELF.o
+_XA_IV32_sparc=xa2.0_iv32_sparcELF.o
+_XA_EXT_sparc=.Z
+
+_XA_CYUV_x86=xa1.0_cyuv_linuxELFg21.o
+_XA_CVID_x86=xa2.0_cvid_linuxELFg21.o
+_XA_IV32_x86=xa2.1_iv32_linuxELFg21.o
+_XA_EXT_x86=.gz
+
+_XA_CYUV_ppc=xa1.0_cyuv_linuxPPC.o
+_XA_CVID_ppc=xa2.0_cvid_linuxPPC.o
+_XA_IV32_ppc=xa2.0_iv32_linuxPPC.o
+_XA_EXT_ppc=.Z
+
+MY_P="xanim_exporting_edition"
+
+# This might leave _XA_EXT empty and that's fine, just indicates no
+# particular support for a given arch
+eval _XA_EXT=\${_XA_EXT_${ARCH}}
+eval _XA_CVID=\${_XA_CVID_${ARCH}}
+eval _XA_CYUV=\${_XA_CYUV_${ARCH}}
+eval _XA_IV32=\${_XA_IV32_${ARCH}}
+
+# Not much we could do here, the modules are predownloaded and
+# xanim-export compiles against them
+QA_EXECSTACK_x86="usr/bin/xanim-export
+ usr/lib/xanim/mods-export/${_XA_CVID}
+ usr/lib/xanim/mods-export/${_XA_CYUV}
+ usr/lib/xanim/mods-export/${_XA_IV32}
+ usr/lib/xanim/mods-export/${_XA_CVID/g21/}
+ usr/lib/xanim/mods-export/${_XA_CYUV/g21/}
+ usr/lib/xanim/mods-export/xa2.0_iv32_linuxELF.o"
+
+DESCRIPTION="XAnim with Quicktime and RAW Audio export functions"
+HOMEPAGE="http://heroin.linuxave.net/toys.html"
+SRC_URI="http://heroine.linuxave.net/${MY_P}.tar.gz
+ sparc? (
+ ftp://xanim.va.pubnix.com/modules/${_XA_CYUV_sparc}${_XA_EXT_sparc}
+ ftp://xanim.va.pubnix.com/modules/${_XA_CVID_sparc}${_XA_EXT_sparc}
+ ftp://xanim.va.pubnix.com/modules/${_XA_IV32_sparc}${_XA_EXT_sparc}
+ )
+ ppc? (
+ ftp://xanim.va.pubnix.com/modules/${_XA_CYUV_ppc}${_XA_EXT_ppc}
+ ftp://xanim.va.pubnix.com/modules/${_XA_CVID_ppc}${_XA_EXT_ppc}
+ ftp://xanim.va.pubnix.com/modules/${_XA_IV32_ppc}${_XA_EXT_ppc}
+ )
+ x86? (
+ ftp://xanim.va.pubnix.com/modules/${_XA_CYUV_x86}${_XA_EXT_x86}
+ ftp://xanim.va.pubnix.com/modules/${_XA_CVID_x86}${_XA_EXT_x86}
+ ftp://xanim.va.pubnix.com/modules/${_XA_IV32_x86}${_XA_EXT_x86}
+ )"
+
+LICENSE="XAnim"
+SLOT="0"
+KEYWORDS="ppc sparc x86"
+IUSE=""
+
+RDEPEND="virtual/jpeg
+ media-libs/libpng
+ x11-libs/libXext
+ x11-libs/libXt
+ media-libs/libquicktime"
+DEPEND="${RDEPEND}
+ app-arch/ncompress
+ x11-proto/xextproto
+ x11-proto/xproto
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ if [[ -n ${_XA_EXT} ]]; then
+ cd "${S}"/mods || die
+ unpack ${_XA_CVID}${_XA_EXT}
+ unpack ${_XA_CYUV}${_XA_EXT}
+ unpack ${_XA_IV32}${_XA_EXT}
+ fi
+
+ cd "${S}"
+ rm -f xanim
+ epatch "${FILESDIR}"/${PV}-gentoo.patch \
+ "${FILESDIR}"/${PV}-implicit_funcs.patch
+}
+
+src_compile() {
+ tc-export CC
+ make \
+ XA_IV32_LIB=mods/${_XA_CYUV} \
+ XA_CVID_LIB=mods/${_XA_CVID} \
+ XA_CYUV_LIB=mods/${_XA_IV32} \
+ OPTIMIZE="${CFLAGS}" \
+ || die "main make failed"
+}
+
+src_install() {
+ newbin xanim xanim-export
+ insinto /usr/lib/xanim/mods-export
+ doins mods/*
+ dodoc README*
+ dodoc docs/README.* docs/*.readme docs/*.doc
+}