summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-26 09:59:41 +0100
committerSam James <sam@gentoo.org>2021-10-26 09:59:51 +0100
commit0d5a3a7b354d34e05c92a2a8dba66510122d8b0a (patch)
tree798311ad6b6e525202424d52afe3cc10cb416167 /media-video
parentgnome-extra/gnome-shell-extension-bluetooth-quick-connect: Bump to v25 (diff)
downloadgentoo-0d5a3a7b354d34e05c92a2a8dba66510122d8b0a.tar.gz
gentoo-0d5a3a7b354d34e05c92a2a8dba66510122d8b0a.tar.bz2
gentoo-0d5a3a7b354d34e05c92a2a8dba66510122d8b0a.zip
media-video/pipewire: add build fixes for some arches
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/pipewire/files/pipewire-0.3.39-fix-build-some-arches.patch35
-rw-r--r--media-video/pipewire/pipewire-0.3.39-r1.ebuild2
2 files changed, 37 insertions, 0 deletions
diff --git a/media-video/pipewire/files/pipewire-0.3.39-fix-build-some-arches.patch b/media-video/pipewire/files/pipewire-0.3.39-fix-build-some-arches.patch
new file mode 100644
index 000000000000..fe5392e29a3a
--- /dev/null
+++ b/media-video/pipewire/files/pipewire-0.3.39-fix-build-some-arches.patch
@@ -0,0 +1,35 @@
+https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/651f0decea5f83730c271e9bed03cdd0048fcd49.patch
+https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/2cddd4a775c145570f4a8a30d28b57f551d43206.patch
+
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Thu, 21 Oct 2021 11:09:48 +0200
+Subject: [PATCH] cpu: fix compilation on some architectures
+
+--- a/spa/plugins/support/cpu.c
++++ b/spa/plugins/support/cpu.c
+@@ -270,7 +270,7 @@ impl_init(const struct spa_handle_factory *factory,
+ if ((str = spa_dict_lookup(info, SPA_KEY_CPU_VM_TYPE)) != NULL)
+ this->vm_type = atoi(str);
+ if ((str = spa_dict_lookup(info, SPA_KEY_CPU_ZERO_DENORMALS)) != NULL)
+- impl_cpu_zero_denormals(this, spa_atob(str));
++ spa_cpu_zero_denormals(&this->cpu, spa_atob(str));
+ }
+
+ spa_log_debug(this->log, "%p: count:%d align:%d flags:%08x",
+
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Mon, 25 Oct 2021 16:32:16 +0200
+Subject: [PATCH] cpu: disable VFP asm when not available
+
+Fixes #1746
+--- a/spa/plugins/support/cpu-arm.c
++++ b/spa/plugins/support/cpu-arm.c
+@@ -143,7 +143,7 @@ static int arm_zero_denormals(void *object, bool enable)
+ "msr fpcr, %0 \n"
+ "isb \n"
+ : "=r"(cw)::"memory");
+-#else
++#elif (defined(__VFP_FP__) && !defined(__SOFTFP__))
+ uint32_t cw;
+ if (enable)
+ __asm__ __volatile__(
diff --git a/media-video/pipewire/pipewire-0.3.39-r1.ebuild b/media-video/pipewire/pipewire-0.3.39-r1.ebuild
index 3c425733a524..0b9ee48f0903 100644
--- a/media-video/pipewire/pipewire-0.3.39-r1.ebuild
+++ b/media-video/pipewire/pipewire-0.3.39-r1.ebuild
@@ -100,6 +100,8 @@ DOCS=( {README,INSTALL}.md NEWS )
PATCHES=(
"${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
+ # Upstream
+ "${FILESDIR}"/${P}-fix-build-some-arches.patch
)
# limitsdfile related code taken from =sys-auth/realtime-base-0.1