summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-05-28 20:48:11 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-05-30 23:25:00 +0200
commit1d5d25a78eb1981658d579de21f8569a4da58210 (patch)
tree98b049d2a8da7d9945d02efcea0bbedbb5e36836 /media-video
parentdev-libs/jemalloc: Major bug fixes, refer to upstream changelog (diff)
downloadgentoo-1d5d25a78eb1981658d579de21f8569a4da58210.tar.gz
gentoo-1d5d25a78eb1981658d579de21f8569a4da58210.tar.bz2
gentoo-1d5d25a78eb1981658d579de21f8569a4da58210.zip
media-video/syncplay: add live version.
Closes: https://github.com/gentoo/gentoo/pull/4787
Diffstat (limited to 'media-video')
-rw-r--r--media-video/syncplay/syncplay-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-video/syncplay/syncplay-9999.ebuild b/media-video/syncplay/syncplay-9999.ebuild
new file mode 100644
index 000000000000..eec07d40d080
--- /dev/null
+++ b/media-video/syncplay/syncplay-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit git-r3 python-r1
+
+MY_PV=${PV/_rc/-RC}
+
+DESCRIPTION="Client/server to synchronize media playback"
+HOMEPAGE="http://syncplay.pl"
+EGIT_REPO_URI="https://github.com/Syncplay/${PN}.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+client +server gui vlc"
+REQUIRED_USE="vlc? ( client )
+ gui? ( client )
+ ${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ || (
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ )
+ gui? ( dev-python/pyside[${PYTHON_USEDEP}] )
+ vlc? ( media-video/vlc[lua] )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ if ! use gui; then
+ sed -i 's/"noGui": False,/"noGui": True,/' \
+ syncplay/ui/ConfigurationGetter.py \
+ || die "Failed to patch ConfigurationGetter.py"
+ fi
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
+ use client && \
+ emake "${MY_MAKEOPTS[@]}" VLC_SUPPORT=$(usex vlc true false) install-client
+ use server && \
+ emake "${MY_MAKEOPTS[@]}" install-server
+}
+
+pkg_postinst() {
+ if use client; then
+ einfo "Syncplay supports the following players:"
+ einfo "media-video/mpv, media-video/mplayer2, media-video/vlc"
+ fi
+}