summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-09 20:31:51 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-09 20:33:53 +0100
commit2ddc3f5c20bb6b7d1504483997c7e78bc462ac34 (patch)
treebcc953fee10a59f34eda7d6d91d82db48e35e40a /media-video
parentmedia-video/tivodecode: Bump to EAPI 7 (diff)
downloadgentoo-2ddc3f5c20bb6b7d1504483997c7e78bc462ac34.tar.gz
gentoo-2ddc3f5c20bb6b7d1504483997c7e78bc462ac34.tar.bz2
gentoo-2ddc3f5c20bb6b7d1504483997c7e78bc462ac34.zip
media-video/vstrip: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697264 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vstrip/files/vstrip-0.8f-gentoo.patch12
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild21
2 files changed, 16 insertions, 17 deletions
diff --git a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
index 77328b091247..d4be5a2ea783 100644
--- a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
+++ b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile 2003-10-12 02:25:31.000000000 +0000
+--- a/Makefile
++++ b/Makefile 2003-10-12 02:25:31.000000000 +0000
@@ -4,7 +4,7 @@
### Sources
@@ -20,8 +20,8 @@
file_io.o : s_types.h file_io.h file_io.c
in_buffer.o : s_types.h file_io.h in_buffer.h in_buffer.c
main.o : s_types.h file_io.h vstrip.h main.c
---- dvd2avi_plugin.c
-+++ dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
+--- a/dvd2avi_plugin.c
++++ b/dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
@@ -6,13 +6,17 @@
*************************************************************************/
@@ -50,8 +50,8 @@
lba = (dword)(fposition / fio_SECTOR_SIZE);
_close(fp);
---- file_io.c
-+++ file_io.c 2003-10-12 02:24:46.000000000 +0000
+--- a/file_io.c
++++ b/file_io.c 2003-10-12 02:24:46.000000000 +0000
@@ -32,7 +32,7 @@
fp = _open(name, _O_BINARY | _O_RDONLY); // check size
if (fp != -1)
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
index ebf44df3a614..7aa923068945 100644
--- a/media-video/vstrip/vstrip-0.8f.ebuild
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils toolchain-funcs
@@ -15,24 +15,23 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND="app-arch/unzip"
-RDEPEND=""
S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-gentoo.patch
edos2unix *.c *.h
- for file in *.c *.h ; do
- echo >>$file
+ local f
+ for f in *.c *.h ; do
+ echo >> "${f}" || die
done
+
+ default
}
src_compile() {
- emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)" || die "emake failed."
+ emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)"
}
src_install() {