summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklāvs Koļesņikovs <89q1r14hd@relay.firefox.com>2021-11-17 01:19:42 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-11-17 08:59:06 +0200
commit30127522ee8b23f3bb8f8079cc39f875ef27213a (patch)
treed0e08f8904d82148e2e0874c3126e1e829638f44 /media-video
parentmedia-video/wireplumber: update instructions on how to enable it (diff)
downloadgentoo-30127522ee8b23f3bb8f8079cc39f875ef27213a.tar.gz
gentoo-30127522ee8b23f3bb8f8079cc39f875ef27213a.tar.bz2
gentoo-30127522ee8b23f3bb8f8079cc39f875ef27213a.zip
media-video/pipewire: update elog to use --force and not omit --now
Using --now is a dangerous action when software versions are updated, unless the user is instructed to also restart the daemons. It's safer to reconfigure things for the next bootup but leave the current session as it is. Because of the annoying pipewire-session-manager.service alias which may exist if enable was done on certain previous PipeWire version(s), it's best to do WirePlumber enablement with --force flag to allow it to overwrite the alias symlink with a new one pointing to itself. Closes: https://bugs.gentoo.org/823104 Signed-off-by: Niklāvs Koļesņikovs <89q1r14hd@relay.firefox.com> Closes: https://github.com/gentoo/gentoo/pull/22977 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/pipewire/pipewire-0.3.40-r1.ebuild20
-rw-r--r--media-video/pipewire/pipewire-9999.ebuild20
2 files changed, 24 insertions, 16 deletions
diff --git a/media-video/pipewire/pipewire-0.3.40-r1.ebuild b/media-video/pipewire/pipewire-0.3.40-r1.ebuild
index 60d1d5d9bcd1..93882727fc56 100644
--- a/media-video/pipewire/pipewire-0.3.40-r1.ebuild
+++ b/media-video/pipewire/pipewire-0.3.40-r1.ebuild
@@ -224,23 +224,26 @@ pkg_postinst() {
fi
if use systemd; then
- elog "To use PipeWire for audio, the user units must be manually enabled"
- elog "by running this command as each user you use for desktop activities:"
+ elog "When switching from PulseAudio, you may need to disable PulseAudio:"
elog
- elog " systemctl --user enable --now pipewire.socket pipewire-pulse.socket"
+ elog " systemctl --user disable pulseaudio.service pulseaudio.socket"
elog
- elog "When switching from PulseAudio, do not forget to disable PulseAudio likewise:"
+ elog "To use PipeWire, the user units must be manually enabled"
+ elog "by running this command as each user you use for desktop activities:"
elog
- elog " systemctl --user disable --now pulseaudio.service pulseaudio.socket"
+ elog " systemctl --user enable pipewire.socket pipewire-pulse.socket"
elog
elog "A reboot is recommended to avoid interferences from still running"
elog "PulseAudio daemon."
elog
- elog "Both, new users and those upgrading, need to enable WirePlumber"
+ elog "Both new users and those upgrading need to enable WirePlumber"
elog "for relevant users:"
elog
- elog " systemctl --user enable --now wireplumber.service"
+ elog " systemctl --user disable pipewire-media-session.service"
+ elog " systemctl --user --force enable wireplumber.service"
elog
+ elog "Root user may replace --user with --global to change system default"
+ elog "configuration for all of the above commands."
else
ewarn "PipeWire daemon startup has been moved to a launcher script!"
ewarn "Make sure that ${EROOT}/etc/pipewire/pipewire.conf either does not exist or no"
@@ -273,6 +276,7 @@ pkg_postinst() {
elog "its config, please start by copying default config from ${EROOT}/usr/share/pipewire"
elog "and just override the sections you want to change."
fi
+ elog
elog "For latest tips and tricks, troubleshooting information and documentation"
elog "in general, please refer to https://wiki.gentoo.org/wiki/PipeWire"
@@ -284,7 +288,7 @@ pkg_postinst() {
if has_version 'net-misc/ofono' ; then
ewarn "Native backend has become default. Please disable oFono via:"
if systemd_is_booted ; then
- ewarn "systemctl disable --now ofono"
+ ewarn "systemctl disable ofono"
else
ewarn "rc-update delete ofono"
fi
diff --git a/media-video/pipewire/pipewire-9999.ebuild b/media-video/pipewire/pipewire-9999.ebuild
index 60d1d5d9bcd1..93882727fc56 100644
--- a/media-video/pipewire/pipewire-9999.ebuild
+++ b/media-video/pipewire/pipewire-9999.ebuild
@@ -224,23 +224,26 @@ pkg_postinst() {
fi
if use systemd; then
- elog "To use PipeWire for audio, the user units must be manually enabled"
- elog "by running this command as each user you use for desktop activities:"
+ elog "When switching from PulseAudio, you may need to disable PulseAudio:"
elog
- elog " systemctl --user enable --now pipewire.socket pipewire-pulse.socket"
+ elog " systemctl --user disable pulseaudio.service pulseaudio.socket"
elog
- elog "When switching from PulseAudio, do not forget to disable PulseAudio likewise:"
+ elog "To use PipeWire, the user units must be manually enabled"
+ elog "by running this command as each user you use for desktop activities:"
elog
- elog " systemctl --user disable --now pulseaudio.service pulseaudio.socket"
+ elog " systemctl --user enable pipewire.socket pipewire-pulse.socket"
elog
elog "A reboot is recommended to avoid interferences from still running"
elog "PulseAudio daemon."
elog
- elog "Both, new users and those upgrading, need to enable WirePlumber"
+ elog "Both new users and those upgrading need to enable WirePlumber"
elog "for relevant users:"
elog
- elog " systemctl --user enable --now wireplumber.service"
+ elog " systemctl --user disable pipewire-media-session.service"
+ elog " systemctl --user --force enable wireplumber.service"
elog
+ elog "Root user may replace --user with --global to change system default"
+ elog "configuration for all of the above commands."
else
ewarn "PipeWire daemon startup has been moved to a launcher script!"
ewarn "Make sure that ${EROOT}/etc/pipewire/pipewire.conf either does not exist or no"
@@ -273,6 +276,7 @@ pkg_postinst() {
elog "its config, please start by copying default config from ${EROOT}/usr/share/pipewire"
elog "and just override the sections you want to change."
fi
+ elog
elog "For latest tips and tricks, troubleshooting information and documentation"
elog "in general, please refer to https://wiki.gentoo.org/wiki/PipeWire"
@@ -284,7 +288,7 @@ pkg_postinst() {
if has_version 'net-misc/ofono' ; then
ewarn "Native backend has become default. Please disable oFono via:"
if systemd_is_booted ; then
- ewarn "systemctl disable --now ofono"
+ ewarn "systemctl disable ofono"
else
ewarn "rc-update delete ofono"
fi