summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-10-27 10:56:55 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-10-27 10:57:17 +0300
commit3ac2cba9a86414345444eaebdbd69db695848046 (patch)
tree1828603dd6d49f46d015a554e144773d672e1085 /media-video
parentmedia-video/mpv: multiple fixes (diff)
downloadgentoo-3ac2cba9a86414345444eaebdbd69db695848046.tar.gz
gentoo-3ac2cba9a86414345444eaebdbd69db695848046.tar.bz2
gentoo-3ac2cba9a86414345444eaebdbd69db695848046.zip
media-video/mpv: Sync live ebuild
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 575ea9a56dac..5109639d545c 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -11,7 +11,7 @@ WAF_PV=2.0.9
inherit eapi7-ver flag-o-matic gnome2-utils pax-utils python-r1 toolchain-funcs waf-utils xdg-utils
DESCRIPTION="Media player based on MPlayer and mplayer2"
-HOMEPAGE="https://mpv.io/"
+HOMEPAGE="https://mpv.io/ https://github.com/mpv-player/mpv"
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -99,8 +99,8 @@ COMMON_DEPEND="
vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
vdpau? ( x11-libs/libvdpau )
vulkan? (
+ media-libs/libplacebo[vulkan]
media-libs/shaderc
- media-libs/vulkan-loader[X?,wayland?]
)
wayland? (
>=dev-libs/wayland-1.6.0
@@ -169,7 +169,7 @@ src_configure() {
$(use_enable doc html-build)
$(use_enable doc pdf-build)
- $(use_enable doc manpage build)
+ $(use_enable doc manpage-build)
$(use_enable cplugins)
$(use_enable test)
@@ -242,13 +242,11 @@ src_configure() {
$(use_enable dvb dvbin)
# Miscellaneous features:
- --disable-apple-remote # Needs testing first. See Gentoo bug 577332.
$(use_enable zimg)
)
if use vaapi && use X; then
mywafargs+=(
- $(use_enable opengl vaapi-glx)
$(use_enable egl vaapi-x-egl)
)
fi
@@ -264,6 +262,8 @@ src_configure() {
--disable-apple-remote
--disable-macos-touchbar
--disable-macos-cocoa-cb
+ --disable-tvos
+ --disable-egl-angle-win32
)
# Create reproducible non-live builds.