summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-06-02 11:30:17 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2016-06-02 11:31:01 +0200
commit53eace1f6281067889b6200682253e5c43941a79 (patch)
tree1b4e7e9e5e03a598c8e26dff9965e8ab04da16ac /media-video
parentdev-libs/iksemel: Fix building with >=net-libs/gnutls-3.4.0 (diff)
downloadgentoo-53eace1f6281067889b6200682253e5c43941a79.tar.gz
gentoo-53eace1f6281067889b6200682253e5c43941a79.tar.bz2
gentoo-53eace1f6281067889b6200682253e5c43941a79.zip
media-video/raspberrypi-omxplayer: applied makefile fix from Ahmet Inan <xdsopl@googlemail.com> from bug #421683 comment #44 and #45
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'media-video')
-rw-r--r--media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch26
-rw-r--r--media-video/raspberrypi-omxplayer/patch26
-rw-r--r--media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild4
3 files changed, 28 insertions, 28 deletions
diff --git a/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
new file mode 100644
index 000000000000..eb65f5d7ad70
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/Makefile-0_p20160528.patch
@@ -0,0 +1,26 @@
+--- omxplayer-9999/Makefile
++++ omxplayer-9999/Makefile
+@@ -2,9 +2,11 @@
+
+ CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
+
+-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
++PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
++
++LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
+
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
++INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
+
+ DIST ?= omxplayer-dist
+
+@@ -51,8 +47,7 @@
+ bash gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvchostif -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+- $(STRIP) omxplayer.bin
++ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)
+
+ help.h: README.md Makefile
+ awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \
diff --git a/media-video/raspberrypi-omxplayer/patch b/media-video/raspberrypi-omxplayer/patch
deleted file mode 100644
index d9b5b6b6d086..000000000000
--- a/media-video/raspberrypi-omxplayer/patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- raspberrypi-omxplayer-9999.ebuild 2016-03-09 00:09:34.000000000 +0100
-+++ raspberrypi-omxplayer-9999.ebuild 2016-05-31 10:01:58.335198495 +0200
-@@ -14,7 +14,7 @@
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="~arm"
--IUSE=""
-+IUSE="X"
-
- RDEPEND="dev-libs/libpcre
- media-fonts/freefont
-@@ -22,8 +22,12 @@
- sys-apps/dbus
- sys-apps/fbset
- virtual/ffmpeg
-- x11-apps/xrefresh
-- x11-apps/xset"
-+ dev-libs/boost
-+ media-libs/freetype:2
-+ X? (
-+ x11-apps/xrefresh
-+ x11-apps/xset
-+ )"
- DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
diff --git a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild
index 4a29459b284e..83e030a1c7eb 100644
--- a/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild
+++ b/media-video/raspberrypi-omxplayer/raspberrypi-omxplayer-0_p20160528.ebuild
@@ -34,11 +34,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/popcornmix-omxplayer-${GIT_COMMIT}"
src_prepare() {
- epatch "${FILESDIR}"/Makefile-0_p20160217.patch \
+ epatch "${FILESDIR}"/Makefile-0_p20160528.patch \
"${FILESDIR}"/fonts-path.patch
cat > Makefile.include << EOF
-LIBS=-lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
+LIBS=-lvchostif -lvchiq_arm -lvcos -lbcm_host -lEGL -lGLESv2 -lopenmaxil -lrt -lpthread
EOF
tc-export CXX