summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:00:11 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:03:57 +0100
commit567dacd9959f8a3760393df7347bc2597ab78549 (patch)
treed497de7ab82c38586fbe151172b91a7c0df2ff82 /media-video
parentmedia-video/droidcam: add version 1.8.1 (diff)
downloadgentoo-567dacd9959f8a3760393df7347bc2597ab78549.tar.gz
gentoo-567dacd9959f8a3760393df7347bc2597ab78549.tar.bz2
gentoo-567dacd9959f8a3760393df7347bc2597ab78549.zip
media-video/droidcam: cleanup old
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/droidcam/Manifest1
-rw-r--r--media-video/droidcam/droidcam-1.8.0-r1.ebuild156
-rw-r--r--media-video/droidcam/droidcam-1.8.0.ebuild144
3 files changed, 0 insertions, 301 deletions
diff --git a/media-video/droidcam/Manifest b/media-video/droidcam/Manifest
index eeff2b0ec94a..12a5981ccc16 100644
--- a/media-video/droidcam/Manifest
+++ b/media-video/droidcam/Manifest
@@ -1,2 +1 @@
-DIST droidcam-1.8.0.tar.gz 84376 BLAKE2B 581e57e2c80dd9662764e399dd797e5893f617e69ee2501a1063d1c51434baf64d7d2b72779debede6d679127f31fa95a4e67953978da591acbf6a41bd05551d SHA512 b448f686562030b352630c6b677a098ecb5041582dd06e57809b04674cb334d02ddfdf1d09b43e1ecc70897e8073714ad6913ab14d894a7679fc433adb3fda82
DIST droidcam-1.8.1.tar.gz 84566 BLAKE2B ba023c98159003bef39eac2fcff211243aa5fb2cc4369a333c5b78c9708b8c34ff9987d6b84628b32e436bab776e0c8c83f75b7c6a788f85831d3d17dd468833 SHA512 58ce6014004edcbf89b4847ed916f9cd2757865172c61e446a04b2f6d93395db1013f0cb31f0b10161bfd83a1436e684891c3457371a3ad62308509bb85b4cf4
diff --git a/media-video/droidcam/droidcam-1.8.0-r1.ebuild b/media-video/droidcam/droidcam-1.8.0-r1.ebuild
deleted file mode 100644
index d81482560789..000000000000
--- a/media-video/droidcam/droidcam-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop linux-mod xdg
-
-DESCRIPTION="Use your phone or tablet as webcam with a v4l device driver and app"
-HOMEPAGE="https://www.dev47apps.com/droidcam/linux/"
-SRC_URI="https://github.com/dev47apps/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="gtk"
-
-# Requires connection to phone/tablet
-RESTRICT="test"
-
-DEPEND="
- app-pda/libplist
- app-pda/libusbmuxd
- dev-libs/glib
- dev-libs/libappindicator:3
- dev-libs/libxml2
- dev-util/android-tools
- media-libs/alsa-lib
- media-libs/libjpeg-turbo
- >=media-libs/speex-1.2.0-r1
- media-video/ffmpeg
- gtk? (
- dev-cpp/gtkmm:3.0
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/pango
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-BUILD_TARGETS="all"
-MODULE_NAMES="v4l2loopback-dc(video:${S}/v4l2loopback:${S}/v4l2loopback)"
-MODULESD_V4L2LOOPBACK_DC_ENABLED="yes"
-
-CONFIG_CHECK="~SND_ALOOP VIDEO_DEV MEDIA_SUPPORT MEDIA_CAMERA_SUPPORT"
-ERROR_SND_ALOOP="CONFIG_SND_ALOOP is optionally required for audio support"
-
-PATCHES="${FILESDIR}/${PN}-makefile-fixes.patch"
-
-src_prepare() {
- if ! use gtk; then
- sed -i -e '/cflags gtk+/d' Makefile || die
- default
- else
- # remove path and extension from Icon and Exec entry
- sed -i -e 's/Icon=\/opt\/droidcam-icon.png/Icon=droidcam/g' \
- -e 's/\/usr\/local\/bin\/droidcam/droidcam/g' \
- droidcam.desktop || die
- sed -i -e 's%/opt/droidcam-icon.png%/usr/share/icons/hicolor/96x96/apps/droidcam.png%g' src/droidcam.c || die
- xdg_src_prepare
- fi
-}
-
-src_configure() {
- set_arch_to_kernel
- default
-}
-
-src_compile() {
- if use gtk; then
- emake droidcam
- fi
- emake droidcam-cli
-
- if linux_chkconfig_present CC_IS_CLANG; then
- BUILD_PARAMS+=' CC=${CHOST}-clang'
- if linux_chkconfig_present LD_IS_LLD; then
- BUILD_PARAMS+=' LD=ld.lld'
- if linux_chkconfig_present LTO_CLANG_THIN; then
- # kernel enables cache by default leading to sandbox violations
- BUILD_PARAMS+=' ldflags-y=--thinlto-cache-dir= LDFLAGS_MODULE=--thinlto-cache-dir='
- fi
- fi
- fi
- export KERNEL_DIR || die
- linux-mod_src_compile
-}
-
-src_test() {
- pushd "v4l2loopback" || die
- default
- ./test || die
- popd || die
-}
-
-src_install() {
- if use gtk; then
- dobin droidcam
- newicon -s 32 icon.png droidcam.png
- newicon -s 96 icon2.png droidcam.png
- domenu droidcam.desktop
- fi
- dobin droidcam-cli
-
- # The cli and gui do not auto load the module if unloaded (why not though?)
- # so we just put it in modules-load.d to make sure it always works
- insinto /etc/modules-load.d
- if linux_config_exists; then
- if linux_chkconfig_module SND_ALOOP; then
- newins - "${PN}.conf" <<-EOF
- v4l2loopback-dc
- snd_aloop
- EOF
- else
- newins - "${PN}.conf" <<-EOF
- v4l2loopback-dc
- EOF
- fi
- fi
-
- einstalldocs
- linux-mod_src_install
-}
-
-pkg_preinst() {
- linux-mod_pkg_preinst
- if use gtk; then
- xdg_pkg_preinst
- fi
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- if use gtk; then
- xdg_pkg_postinst
- else
- elog
- elog "Only droidcam-cli has been installed since 'gtk' flag was not set"
- elog
- fi
-
- elog "The default resolution for v4l2loopback-dc (i.e. droidcam) is 640x480."
- elog "You can change this value in /etc/modprobe.d/v4l2loopback-dc.conf"
- elog
- elog "Links to the Android/iPhone/iPad apps can be found at"
- elog "https://www.dev47apps.com/"
-}
-
-pkg_postrm() {
- linux-mod_pkg_postrm
- if use gtk; then
- xdg_pkg_postrm
- fi
-}
diff --git a/media-video/droidcam/droidcam-1.8.0.ebuild b/media-video/droidcam/droidcam-1.8.0.ebuild
deleted file mode 100644
index 60f47eb1847b..000000000000
--- a/media-video/droidcam/droidcam-1.8.0.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop linux-mod xdg
-
-DESCRIPTION="Use your phone or tablet as webcam with a v4l device driver and app"
-HOMEPAGE="https://www.dev47apps.com/droidcam/linux/"
-SRC_URI="https://github.com/dev47apps/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="gtk"
-
-# Requires connection to phone/tablet
-RESTRICT="test"
-
-DEPEND="
- app-pda/libplist
- app-pda/libusbmuxd
- dev-libs/glib
- dev-libs/libappindicator:3
- dev-libs/libxml2
- dev-util/android-tools
- media-libs/alsa-lib
- media-libs/libjpeg-turbo
- >=media-libs/speex-1.2.0-r1
- media-video/ffmpeg
- gtk? (
- dev-cpp/gtkmm:3.0
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/pango
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-BUILD_TARGETS="all"
-MODULE_NAMES="v4l2loopback-dc(video:${S}/v4l2loopback:${S}/v4l2loopback)"
-MODULESD_V4L2LOOPBACK_DC_ENABLED="yes"
-
-CONFIG_CHECK="~SND_ALOOP VIDEO_DEV MEDIA_SUPPORT MEDIA_CAMERA_SUPPORT"
-ERROR_SND_ALOOP="CONFIG_SND_ALOOP is optionally required for audio support"
-
-PATCHES="${FILESDIR}/${PN}-makefile-fixes.patch"
-
-src_prepare() {
- if ! use gtk; then
- sed -i -e '/cflags gtk+/d' Makefile || die
- default
- else
- # remove path and extension from Icon and Exec entry
- sed -i -e 's/Icon=\/opt\/droidcam-icon.png/Icon=droidcam/g' \
- -e 's/\/usr\/local\/bin\/droidcam/droidcam/g' \
- droidcam.desktop || die
- sed -i -e 's%/opt/droidcam-icon.png%/usr/share/icons/hicolor/96x96/apps/droidcam.png%g' src/droidcam.c || die
- xdg_src_prepare
- fi
-}
-
-src_configure() {
- set_arch_to_kernel
- default
-}
-
-src_compile() {
- if use gtk; then
- emake droidcam
- fi
- emake droidcam-cli
- KERNELRELEASE="${KV_FULL}" linux-mod_src_compile
-}
-
-src_test() {
- pushd "v4l2loopback" || die
- default
- ./test || die
- popd || die
-}
-
-src_install() {
- if use gtk; then
- dobin droidcam
- newicon -s 32 icon.png droidcam.png
- newicon -s 96 icon2.png droidcam.png
- domenu droidcam.desktop
- fi
- dobin droidcam-cli
-
- # The cli and gui do not auto load the module if unloaded (why not though?)
- # so we just put it in modules-load.d to make sure it always works
- insinto /etc/modules-load.d
- if linux_config_exists; then
- if linux_chkconfig_module SND_ALOOP; then
- newins - "${PN}.conf" <<-EOF
- v4l2loopback-dc
- snd_aloop
- EOF
- else
- newins - "${PN}.conf" <<-EOF
- v4l2loopback-dc
- EOF
- fi
- fi
-
- einstalldocs
- linux-mod_src_install
-}
-
-pkg_preinst() {
- if use gtk; then
- xdg_pkg_preinst
- fi
- linux-mod_pkg_preinst
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- if use gtk; then
- xdg_pkg_postinst
- else
- elog
- elog "Only droidcam-cli has been installed since 'gtk' flag was not set"
- elog
- fi
-
- elog "The default resolution for v4l2loopback-dc (i.e. droidcam) is 640x480."
- elog "You can change this value in /etc/modprobe.d/v4l2loopback-dc.conf"
- elog
- elog "Links to the Android/iPhone/iPad apps can be found at"
- elog "https://www.dev47apps.com/"
-}
-
-pkg_postrm() {
- if use gtk; then
- xdg_pkg_postrm
- fi
- linux-mod_pkg_postrm
-}