summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 16:36:27 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 16:36:27 +0100
commit5a56be48993b780b5312a1dc3180d81a716a6a33 (patch)
tree5dd0bf0048a6e2ab34f34d24b13a3f5fe4b3efbd /media-video
parentprofiles/package.mask: Masked net-dns/pdnsd for removal (diff)
downloadgentoo-5a56be48993b780b5312a1dc3180d81a716a6a33.tar.gz
gentoo-5a56be48993b780b5312a1dc3180d81a716a6a33.tar.bz2
gentoo-5a56be48993b780b5312a1dc3180d81a716a6a33.zip
media-video/droidcam: don't hardcode CC
Closes: https://bugs.gentoo.org/828510 Closes: https://bugs.gentoo.org/828509 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/droidcam/droidcam-1.8.1-r1.ebuild (renamed from media-video/droidcam/droidcam-1.8.1.ebuild)0
-rw-r--r--media-video/droidcam/files/droidcam-makefile-fixes.patch23
2 files changed, 19 insertions, 4 deletions
diff --git a/media-video/droidcam/droidcam-1.8.1.ebuild b/media-video/droidcam/droidcam-1.8.1-r1.ebuild
index d81482560789..d81482560789 100644
--- a/media-video/droidcam/droidcam-1.8.1.ebuild
+++ b/media-video/droidcam/droidcam-1.8.1-r1.ebuild
diff --git a/media-video/droidcam/files/droidcam-makefile-fixes.patch b/media-video/droidcam/files/droidcam-makefile-fixes.patch
index 5230c18f0f33..9c6ad4c45c09 100644
--- a/media-video/droidcam/files/droidcam-makefile-fixes.patch
+++ b/media-video/droidcam/files/droidcam-makefile-fixes.patch
@@ -1,8 +1,8 @@
diff --git a/Makefile b/Makefile
-index 7be3c15..099a707 100644
+index 7be3c15..8af0953 100644
--- a/Makefile
+++ b/Makefile
-@@ -6,7 +6,7 @@
+@@ -6,25 +6,23 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
# Use at your own risk. See README file for more details.
@@ -11,7 +11,9 @@ index 7be3c15..099a707 100644
JPEG_INCLUDE ?= $(JPEG_DIR)/include
JPEG_LIB ?= $(JPEG_DIR)/lib`getconf LONG_BIT`
-@@ -16,15 +16,15 @@ GTK = `pkg-config --libs --cflags gtk+-3.0` `pkg-config --libs x11`
+-CC = gcc
+-CFLAGS = -Wall -O2
+ GTK = `pkg-config --libs --cflags gtk+-3.0` `pkg-config --libs x11`
GTK += `pkg-config --cflags --libs appindicator3-0.1`
LIBAV = `pkg-config --libs --cflags libswscale libavutil`
LIBS = -lspeex -lasound -lpthread -lm
@@ -31,7 +33,7 @@ index 7be3c15..099a707 100644
package: clean all
zip "droidcam_$(RELEASE).zip" \
LICENSE README* icon2.png \
-@@ -40,11 +40,11 @@ gresource: .gresource.xml icon2.png
+@@ -40,11 +38,11 @@ gresource: .gresource.xml icon2.png
droidcam-cli: LDLIBS += $(JPEG) $(LIBAV) $(LIBS)
droidcam-cli: src/droidcam-cli.c $(SRC)
@@ -45,3 +47,16 @@ index 7be3c15..099a707 100644
clean:
rm -f droidcam
+diff --git a/v4l2loopback/Makefile b/v4l2loopback/Makefile
+index 28c4502..02356e9 100644
+--- a/v4l2loopback/Makefile
++++ b/v4l2loopback/Makefile
+@@ -11,7 +11,7 @@ install:
+ $(MAKE) -C $(KERNEL_DIR) M=$(PWD) modules_install
+
+ test:
+- gcc test.c -o test
++ $(CC) test.c -o test
+
+ clean:
+ $(MAKE) -C $(KERNEL_DIR) M=$(PWD) clean