summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-22 13:07:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-22 13:21:30 +0200
commit60cce6de0a0c95beab7dc68b919d8393eff21a98 (patch)
treea8b58a908f2af19ba45963fa9221e5ffefdaa601 /media-video
parentmedia-video/guvcview: fix build with ffmpeg4 (diff)
downloadgentoo-60cce6de0a0c95beab7dc68b919d8393eff21a98.tar.gz
gentoo-60cce6de0a0c95beab7dc68b919d8393eff21a98.tar.bz2
gentoo-60cce6de0a0c95beab7dc68b919d8393eff21a98.zip
media-video/ffmpeg: add lv2 useflag
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.0.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild3
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.0.ebuild b/media-video/ffmpeg/ffmpeg-4.0.ebuild
index 848b43d089f6..6bd43cd27f3a 100644
--- a/media-video/ffmpeg/ffmpeg-4.0.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.0.ebuild
@@ -81,7 +81,7 @@ FFMPEG_FLAG_MAP=(
# libavfilter options
appkit
bs2b:libbs2b chromaprint flite:libflite frei0r
- fribidi:libfribidi fontconfig ladspa libass truetype:libfreetype
+ fribidi:libfribidi fontconfig ladspa libass lv2 truetype:libfreetype
rubberband:librubberband zeromq:libzmq zimg:libzimg
# libswresample options
libsoxr
@@ -216,6 +216,7 @@ RDEPEND="
libilbc? ( >=media-libs/libilbc-2[${MULTILIB_USEDEP}] )
libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
+ lv2? ( media-libs/lv2[${MULTILIB_USEDEP}] media-libs/lilv[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
mmal? ( media-libs/raspberrypi-userland )
modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 53a1b9bfb06f..378feaea8318 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -81,7 +81,7 @@ FFMPEG_FLAG_MAP=(
# libavfilter options
appkit
bs2b:libbs2b chromaprint flite:libflite frei0r
- fribidi:libfribidi fontconfig ladspa libass truetype:libfreetype
+ fribidi:libfribidi fontconfig ladspa libass lv2 truetype:libfreetype
rubberband:librubberband zeromq:libzmq zimg:libzimg
# libswresample options
libsoxr
@@ -216,6 +216,7 @@ RDEPEND="
libilbc? ( >=media-libs/libilbc-2[${MULTILIB_USEDEP}] )
libsoxr? ( >=media-libs/soxr-0.1.0[${MULTILIB_USEDEP}] )
libv4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
+ lv2? ( media-libs/lv2[${MULTILIB_USEDEP}] media-libs/lilv[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
mmal? ( media-libs/raspberrypi-userland )
modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 835207d47b64..e72693241814 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -36,6 +36,7 @@
<flag name="librtmp">Enables Real Time Messaging Protocol using librtmp (<pkg>media-video/rtmpdump</pkg>) in addition to FFmpeg's native implementation.</flag>
<flag name="libsoxr">Enables audio resampling through <pkg>media-libs/soxr</pkg>.</flag>
<flag name="libv4l">Uses <pkg>media-libs/libv4l</pkg> for video4linux instead of direct calls. Adds support for more devices via the userspace library.</flag>
+ <flag name="lv2">Enables lv2 audio filter wrapper.</flag>
<flag name="mipsdspr1">Enables MIPS DSP ASE R1 optimizations.</flag>
<flag name="mipsdspr2">Enables MIPS DSP ASE R2 optimizations.</flag>
<flag name="mipsfpu">Enables floating point MIPS optimizations.</flag>