summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-18 01:23:13 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-18 01:27:29 +0100
commit63861c0d8e631387566113508b80cfc93930ca43 (patch)
tree4b2c9d53782dc6723b2d4088573694f06504be4d /media-video
parentx11-misc/safeeyes: Drop old (diff)
downloadgentoo-63861c0d8e631387566113508b80cfc93930ca43.tar.gz
gentoo-63861c0d8e631387566113508b80cfc93930ca43.tar.bz2
gentoo-63861c0d8e631387566113508b80cfc93930ca43.zip
media-video/vlc: Disable vlc-cache-gen during build
Tested-by: Andrius Štikonas <andrius@stikonas.eu> Closes: https://bugs.gentoo.org/608256 Closes: https://bugs.gentoo.org/564842 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/vlc-2.2.8-r1.ebuild8
-rw-r--r--media-video/vlc/vlc-2.2.9999.ebuild10
-rw-r--r--media-video/vlc/vlc-3.0.9999.ebuild10
-rw-r--r--media-video/vlc/vlc-9999.ebuild10
4 files changed, 35 insertions, 3 deletions
diff --git a/media-video/vlc/vlc-2.2.8-r1.ebuild b/media-video/vlc/vlc-2.2.8-r1.ebuild
index 997cd366883d..e5ea17223128 100644
--- a/media-video/vlc/vlc-2.2.8-r1.ebuild
+++ b/media-video/vlc/vlc-2.2.8-r1.ebuild
@@ -242,6 +242,10 @@ src_prepare() {
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
fi
+ # Disable running of vlc-cache-gen, we do that in pkg_postinst
+ sed -e "/test.*build.*host/s/\$(host)/nothanks/" \
+ -i Makefile.am -i bin/Makefile.am || die "Failed to disable vlc-cache-gen"
+
eautoreconf
# Disable automatic running of tests.
@@ -466,6 +470,10 @@ pkg_postinst() {
}
pkg_postrm() {
+ if [[ -e /usr/lib64/vlc/plugins/plugins.dat ]]; then
+ rm /usr/lib64/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ fi
+
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update
diff --git a/media-video/vlc/vlc-2.2.9999.ebuild b/media-video/vlc/vlc-2.2.9999.ebuild
index 5d8fafca1886..e9fdb939b366 100644
--- a/media-video/vlc/vlc-2.2.9999.ebuild
+++ b/media-video/vlc/vlc-2.2.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -242,6 +242,10 @@ src_prepare() {
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
fi
+ # Disable running of vlc-cache-gen, we do that in pkg_postinst
+ sed -e "/test.*build.*host/s/\$(host)/nothanks/" \
+ -i Makefile.am -i bin/Makefile.am || die "Failed to disable vlc-cache-gen"
+
eautoreconf
# Disable automatic running of tests.
@@ -466,6 +470,10 @@ pkg_postinst() {
}
pkg_postrm() {
+ if [[ -e /usr/lib64/vlc/plugins/plugins.dat ]]; then
+ rm /usr/lib64/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ fi
+
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update
diff --git a/media-video/vlc/vlc-3.0.9999.ebuild b/media-video/vlc/vlc-3.0.9999.ebuild
index 044aa2ff014a..f97e73f1b770 100644
--- a/media-video/vlc/vlc-3.0.9999.ebuild
+++ b/media-video/vlc/vlc-3.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -267,6 +267,10 @@ src_prepare() {
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
fi
+ # Disable running of vlc-cache-gen, we do that in pkg_postinst
+ sed -e "/test.*build.*host/s/\$(host)/nothanks/" \
+ -i Makefile.am -i bin/Makefile.am || die "Failed to disable vlc-cache-gen"
+
eautoreconf
# Disable automatic running of tests.
@@ -473,6 +477,10 @@ pkg_postinst() {
}
pkg_postrm() {
+ if [[ -e /usr/lib64/vlc/plugins/plugins.dat ]]; then
+ rm /usr/lib64/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ fi
+
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 86a7661c3f4d..d4545b0e1f96 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -267,6 +267,10 @@ src_prepare() {
sed -i 's/ --started-from-file//' share/vlc.desktop.in || die
fi
+ # Disable running of vlc-cache-gen, we do that in pkg_postinst
+ sed -e "/test.*build.*host/s/\$(host)/nothanks/" \
+ -i Makefile.am -i bin/Makefile.am || die "Failed to disable vlc-cache-gen"
+
eautoreconf
# Disable automatic running of tests.
@@ -473,6 +477,10 @@ pkg_postinst() {
}
pkg_postrm() {
+ if [[ -e /usr/lib64/vlc/plugins/plugins.dat ]]; then
+ rm /usr/lib64/vlc/plugins/plugins.dat || die "Failed to rm plugins.dat"
+ fi
+
gnome2_icon_cache_update
xdg_mimeinfo_database_update
xdg_desktop_database_update