summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-06-23 11:18:41 -0400
committerCraig Andrews <candrews@gentoo.org>2020-06-23 11:21:55 -0400
commit696930fe2d511bab765019d8a22178143b5b3c69 (patch)
tree3d63ca2ee51a8b4f231cddff2cff8ddd9962635f /media-video
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-696930fe2d511bab765019d8a22178143b5b3c69.tar.gz
gentoo-696930fe2d511bab765019d8a22178143b5b3c69.tar.bz2
gentoo-696930fe2d511bab765019d8a22178143b5b3c69.zip
media-video/rtmpdump: Don't call ar directly
Closes: https://bugs.gentoo.org/721028 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild2
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
index 09a4ebf6598d..a3b8a59caac3 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
@@ -85,7 +85,7 @@ multilib_src_compile() {
if ! multilib_is_native_abi; then
cd librtmp || die
fi
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
}
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index df14880ddc1b..4e6b50ef0fc2 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -85,7 +85,7 @@ multilib_src_compile() {
if ! multilib_is_native_abi; then
cd librtmp || die
fi
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
}