summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-05-05 17:03:35 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-05-05 17:04:51 +0200
commit728ceb5d902caeb288610ec4bb20190ad3278f72 (patch)
tree9530874dc971732e18c77a11fe2c76ee0ebaeafc /media-video
parentmedia-sound/mumble: Bump to version 1.3.1_rc1 (diff)
downloadgentoo-728ceb5d902caeb288610ec4bb20190ad3278f72.tar.gz
gentoo-728ceb5d902caeb288610ec4bb20190ad3278f72.tar.bz2
gentoo-728ceb5d902caeb288610ec4bb20190ad3278f72.zip
media-video/simplescreenrecorder: Bump to version 0.4.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/simplescreenrecorder/Manifest1
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.4.1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/media-video/simplescreenrecorder/Manifest b/media-video/simplescreenrecorder/Manifest
index 74c8cbdd47d5..2510abf8ea5c 100644
--- a/media-video/simplescreenrecorder/Manifest
+++ b/media-video/simplescreenrecorder/Manifest
@@ -1,2 +1,3 @@
DIST simplescreenrecorder-0.3.11.tar.gz 1823944 BLAKE2B b7692ad158b4784f0222dd47227b85d33aae7eb416ed87d2eda1040027c910ec8d0ebe6a7e164e77cb9c3f6f2756e15fe97a7f05f45c92465473d2ae90e86b34 SHA512 5919774a00cd7015cd7db40561efaea43809b9465508b7770db9eb0fc87f338746e5cd4a79a0ab6c09e516257fa80184c3dcb5ab400c0ef2c0a8cf50ea2a073f
DIST simplescreenrecorder-0.4.0.tar.gz 1867593 BLAKE2B 0997c4e72c142ebfa74658c1fd27d8d01ceb3810f659df0bf899004224d3944a58476fd6b54b318d712fa4d284684a221f387c7e3e63d4b397312ab9e0786988 SHA512 aa4970aba010884153c9d3155a0869288a5b9b8723cf617471148ad875f1af29f594403c1682303345c578cc0dc3f0a4b3596e4937d3afa949a652b83dcd0b36
+DIST simplescreenrecorder-0.4.1.tar.gz 1893293 BLAKE2B d05765788b23073bd03997b92dfa34e3437514ccd88216dea429305f4d43ac25019d141b248ee4a4844d72fd6a87f196579e876ee16a235da34cb3f2404ce5e3 SHA512 b890fafb65a87c298562d25388384577408d7ccbb0b1280bb4fdad198c9b9581893e68b99aa9e478a61c59736689ae40be0f30132d56ee9a9796b8885541d8d5
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.1.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.1.ebuild
new file mode 100644
index 000000000000..98efd341c929
--- /dev/null
+++ b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib flag-o-matic xdg
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="A Simple Screen Recorder"
+HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder"
+LICENSE="GPL-3"
+PKGNAME="ssr"
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git"
+ EGIT_BOOTSTRAP=""
+else
+ SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PKGNAME}-${PV}"
+fi
+
+SLOT="0"
+IUSE="+asm jack mp3 pulseaudio theora vorbis vpx x264"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib:0=
+ media-libs/mesa[${MULTILIB_USEDEP},X(+)]
+ media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+pkg_pretend() {
+ if [[ "${ABI}" == amd64 ]]; then
+ elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
+ elog "When added 32bit GLInject libraries are also included. This is"
+ elog "required if you want to use OpenGL recording on 32bit applications."
+ elog
+ fi
+
+ if has_version media-video/ffmpeg[x264] && has_version media-libs/x264[10bit] ; then
+ ewarn
+ ewarn "media-libs/x264 is currently built with 10bit useflag."
+ ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
+ ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
+ ewarn "record videos with x264."
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ # QT requires -fPIC. Compile fails otherwise.
+ # Recently removed from the default compile options upstream
+ # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
+ append-flags -fPIC
+}
+
+src_prepare() {
+ # required because xdg.eclass overrides default cmake_src_prepare
+ cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_X86_ASM="$(usex asm)"
+ -DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)"
+ -DWITH_JACK="$(multilib_native_usex jack)"
+ -DWITH_GLINJECT="true"
+ )
+
+ if multilib_is_native_abi ; then
+ mycmakeargs+=(
+ -DENABLE_32BIT_GLINJECT="false"
+ -DWITH_QT5="true"
+ )
+ else
+ mycmakeargs+=(
+ # https://bugs.gentoo.org/660438
+ -DCMAKE_INSTALL_LIB32DIR="$(get_libdir)"
+ -DENABLE_32BIT_GLINJECT="true"
+ -DWITH_SIMPLESCREENRECORDER="false"
+ )
+ fi
+
+ cmake_src_configure
+}