summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-03 09:29:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-03 09:29:47 +0200
commit7bfca9bc0671786f810c9ebe92e6f07e6c57e117 (patch)
tree7d91be6c0299059369cfac0bf5444dd4da6aac41 /media-video
parentx11-libs/libva: Bump to 1.8.0. (diff)
downloadgentoo-7bfca9bc0671786f810c9ebe92e6f07e6c57e117.tar.gz
gentoo-7bfca9bc0671786f810c9ebe92e6f07e6c57e117.tar.bz2
gentoo-7bfca9bc0671786f810c9ebe92e6f07e6c57e117.zip
media-video/libva-utils: Initial import. Split out of x11-libs/libva
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libva-utils/Manifest1
-rw-r--r--media-video/libva-utils/libva-utils-1.8.0.ebuild58
-rw-r--r--media-video/libva-utils/libva-utils-9999.ebuild58
-rw-r--r--media-video/libva-utils/metadata.xml11
4 files changed, 128 insertions, 0 deletions
diff --git a/media-video/libva-utils/Manifest b/media-video/libva-utils/Manifest
new file mode 100644
index 000000000000..2552fd3afbe3
--- /dev/null
+++ b/media-video/libva-utils/Manifest
@@ -0,0 +1 @@
+DIST libva-utils-1.8.0.tar.gz 1011595 SHA256 2a7590c8428d0b453b004702c4c515669403cea27f9f17b2560b38da337ec943 SHA512 020cf1d5af7a78ecb4806afe69d34106525086f10b007dddb8d36c0243b670c311df537d969c8b60222b4afc7bfc08c1d594843339af72618886eecfd03887ec WHIRLPOOL 46e76c555a69878e5cb553f3895752aafc821012afefec69b55f35014659e49ab3e30bcd5f94a9ffd86cd1c3fee467d215f58b3e10b69c54d1e630d78144a4b3
diff --git a/media-video/libva-utils/libva-utils-1.8.0.ebuild b/media-video/libva-utils/libva-utils-1.8.0.ebuild
new file mode 100644
index 000000000000..ef34dbe2e6cd
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-1.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/01org/libva-utils"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils ${SCM} multilib
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/01org/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm test wayland X"
+
+RDEPEND="
+ >=x11-libs/libva-1.8[drm?,wayland?,X?]
+ drm? ( >=x11-libs/libdrm-2.4 )
+ X? (
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ )
+ wayland? ( >=dev-libs/wayland-1.0.6 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ $(use_enable test tests)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-video/libva-utils/libva-utils-9999.ebuild b/media-video/libva-utils/libva-utils-9999.ebuild
new file mode 100644
index 000000000000..ef34dbe2e6cd
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SCM=git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/01org/libva-utils"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils ${SCM} multilib
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/01org/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+ KEYWORDS=""
+fi
+IUSE="+drm test wayland X"
+
+RDEPEND="
+ >=x11-libs/libva-1.8[drm?,wayland?,X?]
+ drm? ( >=x11-libs/libdrm-2.4 )
+ X? (
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ )
+ wayland? ( >=dev-libs/wayland-1.0.6 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ $(use_enable test tests)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-video/libva-utils/metadata.xml b/media-video/libva-utils/metadata.xml
new file mode 100644
index 000000000000..b6426fdc4bba
--- /dev/null
+++ b/media-video/libva-utils/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <use>
+ <flag name="drm">Enables VA/DRM API support.</flag>
+ </use>
+</pkgmetadata>