summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-24 02:10:49 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-24 02:11:35 +0100
commit8c595ef0ef77df069f42bd41a1171afdec579e41 (patch)
tree302e678accd076fd982f457ba783880de2073cdb /media-video
parentmedia-gfx/gimp: Merge 2.9.2 into and fix 9999 (bug #569346) (diff)
downloadgentoo-8c595ef0ef77df069f42bd41a1171afdec579e41.tar.gz
gentoo-8c595ef0ef77df069f42bd41a1171afdec579e41.tar.bz2
gentoo-8c595ef0ef77df069f42bd41a1171afdec579e41.zip
media-video/subtitleeditor: version bump to 0.52.1, bug #550764
Drop USE=opengl due to mixing incompatible gtk+:2 and :3. Raise dependency and apply fixes to build with C++11 enabled dependencies. https://bugs.gentoo.org/show_bug.cgi?id=550764 Package-Manager: portage-2.2.26
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleeditor/Manifest1
-rw-r--r--media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch55
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.52.1.ebuild69
3 files changed, 125 insertions, 0 deletions
diff --git a/media-video/subtitleeditor/Manifest b/media-video/subtitleeditor/Manifest
index 75a4bb2b8e58..5b416263cdb4 100644
--- a/media-video/subtitleeditor/Manifest
+++ b/media-video/subtitleeditor/Manifest
@@ -1 +1,2 @@
DIST subtitleeditor-0.41.1.tar.gz 1637940 SHA256 3183f2f9831359f2200194fcc2d360198094c494892ccacd08a28717bffac0d0 SHA512 6e87df6bf1b97fc085387f331fa415be48086b9dabf445e6050ff3ab3c812c8fff72e613959308f07c2e849bf95064c5d288f44dbc266997e7143bbb46615c9d WHIRLPOOL 111163dde1cf17df34e0dfb0aeeb874a98095d6d338ca22138ff13747697d78a2d1be127f344c36286b79f828918ab1c615bccc7e04cc8586b12efe407c76f52
+DIST subtitleeditor-0.52.1.tar.gz 1680875 SHA256 5b3e5fc1f12bcf0d4bcf5014249b6832181bd3b513ac04ee665ec979441412d5 SHA512 a9a7ee78abadf660fe645e36ed69b87131320e04373554adb48dc33df8f36605ed74da3822fe0281b2b75d6f82daddd062b2ae9a12aed44673195fba43adfd4f WHIRLPOOL def330a098b9227cf6db8a74c67d2cd7db724b65f586e22ebf1b08de6de6321849fdeecfe5fd6c0132a814d45d84087b406a05aec7463c04a4355530c3d09c44
diff --git a/media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch b/media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch
new file mode 100644
index 000000000000..9cce5d2d98f2
--- /dev/null
+++ b/media-video/subtitleeditor/files/subtitleeditor-0.52.1-build-fix.patch
@@ -0,0 +1,55 @@
+Fix build errors with gcc-4.9.3 -std=c++11 (after disabling -ansi)
+
+https://gna.org/bugs/?23714
+
+https://bugs.gentoo.org/show_bug.cgi?id=550764
+https://bugs.gentoo.org/show_bug.cgi?id=566328
+
+--- a/src/subtitleview.cc 2015-12-24 01:52:29.322622155 +0100
++++ b/src/subtitleview.cc 2015-12-24 01:52:44.210491213 +0100
+@@ -1363,7 +1363,7 @@
+ {
+ int num;
+ std::istringstream ss(event->string);
+- bool is_num = ss >> num != 0;
++ bool is_num = static_cast<bool>(ss >> num) != 0;
+ // Update only if it's different
+ if(is_num != get_enable_search())
+ set_enable_search(is_num);
+--- a/src/utility.h 2015-12-24 01:49:42.205104858 +0100
++++ b/src/utility.h 2015-12-24 01:50:23.387737071 +0100
+@@ -91,7 +91,7 @@
+ std::istringstream s(src);
+ // return s >> dest != 0;
+
+- bool state = s >> dest != 0;
++ bool state = static_cast<bool>(s >> dest) != 0;
+
+ if(!state)
+ se_debug_message(SE_DEBUG_UTILITY, "string:'%s'failed.", src.c_str());
+--- a/plugins/actions/dialoguize/dialoguize.cc 2015-12-24 01:06:24.125428454 +0100
++++ b/plugins/actions/dialoguize/dialoguize.cc 2015-12-24 01:06:42.630277006 +0100
+@@ -23,7 +23,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+-#include <auto_ptr.h>
++#include <memory>
+ #include "extension/action.h"
+ #include "i18n.h"
+ #include "debug.h"
+--- a/plugins/actions/documentmanagement/documentmanagement.old 2015-12-24 01:17:13.914730337 +0100
++++ b/plugins/actions/documentmanagement/documentmanagement.cc 2015-12-24 01:17:23.339640430 +0100
+@@ -178,9 +178,9 @@
+
+ ui_id = ui->new_merge_id();
+
+- #define ADD_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/"name, name, name);
+- #define ADD_OPEN_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-open/"name, name, name);
+- #define ADD_SAVE_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-save/"name, name, name);
++ #define ADD_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/" name, name, name);
++ #define ADD_OPEN_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-open/" name, name, name);
++ #define ADD_SAVE_UI(name) ui->add_ui(ui_id, "/menubar/menu-file/menu-save/" name, name, name);
+
+ ADD_UI("new-document");
+ ADD_OPEN_UI("open-document");
diff --git a/media-video/subtitleeditor/subtitleeditor-0.52.1.ebuild b/media-video/subtitleeditor/subtitleeditor-0.52.1.ebuild
new file mode 100644
index 000000000000..fa99db5b69c6
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.52.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit flag-o-matic gnome2 versionator
+
+DESCRIPTION="GTK+3 subtitle editing tool"
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug nls"
+# opengl would mix gtk+:2 and :3 which is not possible
+
+RDEPEND="
+ >=app-text/enchant-1.4
+ app-text/iso-codes
+ >=dev-cpp/cairomm-1.12
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-cpp/gstreamermm-1.0:1.0
+ >=dev-cpp/libxmlpp-2.40:2.6
+ dev-libs/glib:2
+ >=dev-libs/libsigc++-2.6:2
+ media-libs/gst-plugins-base:1.0[X,pango]
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-libs/gtk+:3
+ virtual/libintl
+"
+# opengl? (
+# >=dev-cpp/gtkglextmm-1.2.0-r2:1.0
+# virtual/opengl )
+# X needed for video output and pango needed for text overlay
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # ansi overrides -std, see src_configure
+ sed 's/\(CXXFLAGS\) -ansi/\1/' -i configure.ac configure || die
+
+ # fix build issues
+ epatch "${FILESDIR}"/${PN}-0.52.1-build-fix.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Needed with newer gnome mm bindings
+ append-cxxflags -std=c++11
+
+ # Avoid using --enable-debug as it mocks with CXXFLAGS and LDFLAGS
+ use debug && append-cxxflags -DDEBUG
+
+ gnome2_src_configure \
+ --disable-debug \
+ --disable-gl \
+ $(use_enable nls)
+# $(use_enable opengl gl)
+}