summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-03-14 19:26:13 +0300
committerIan Delaney <idella4@gentoo.org>2016-03-15 02:20:05 +0800
commitc0ecbdc63848f418471175376d55ee041894a019 (patch)
tree35de2b28ea0451eea7eac3272749ecb560259012 /media-video
parentwww-apps/airdcpp-webui: bump to 1.0.0 (diff)
downloadgentoo-c0ecbdc63848f418471175376d55ee041894a019.tar.gz
gentoo-c0ecbdc63848f418471175376d55ee041894a019.tar.bz2
gentoo-c0ecbdc63848f418471175376d55ee041894a019.zip
media-video/mpv: revbump to 0.16.0-r2 to backport another regression fix
Backport one more fix [1] for two regressions reported upstream [2,3]. Hopefully it's the final revbump unless something critical pops up. [1]: https://github.com/mpv-player/mpv/commit/c13c9945 [2]: https://github.com/mpv-player/mpv/issues/2920 [3]: https://github.com/mpv-player/mpv/issues/2929 Closes: https://github.com/gentoo/gentoo/pull/1046 Package-Manager: portage-2.2.28
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/files/mpv-0.16.0-add-missing-audio-reconfig-events.patch33
-rw-r--r--media-video/mpv/mpv-0.16.0-r2.ebuild (renamed from media-video/mpv/mpv-0.16.0-r1.ebuild)1
2 files changed, 34 insertions, 0 deletions
diff --git a/media-video/mpv/files/mpv-0.16.0-add-missing-audio-reconfig-events.patch b/media-video/mpv/files/mpv-0.16.0-add-missing-audio-reconfig-events.patch
new file mode 100644
index 000000000000..b01e12616c5a
--- /dev/null
+++ b/media-video/mpv/files/mpv-0.16.0-add-missing-audio-reconfig-events.patch
@@ -0,0 +1,33 @@
+commit c13c9945bf84817ee1dd2d65e58660fb38e23a7f
+Author: wm4 <wm4@nowhere>
+Date: Sun Mar 13 15:52:17 2016 +0100
+
+ player: add missing audio reconfig events
+
+ This also takes care of sending the required property change
+ notifications.
+
+ Fixes #2929 and maybe fixes #2920.
+
+diff --git a/player/audio.c b/player/audio.c
+index f17587a..3a2c60b 100644
+--- a/player/audio.c
++++ b/player/audio.c
+@@ -134,6 +134,8 @@ static int recreate_audio_filters(struct MPContext *mpctx)
+
+ mixer_reinit_audio(mpctx->mixer, mpctx->ao, afs);
+
++ mp_notify(mpctx, MPV_EVENT_AUDIO_RECONFIG, NULL);
++
+ return 0;
+
+ fail:
+@@ -368,6 +370,8 @@ static void reinit_audio_filters_and_output(struct MPContext *mpctx)
+
+ update_playback_speed(mpctx);
+
++ mp_notify(mpctx, MPV_EVENT_AUDIO_RECONFIG, NULL);
++
+ return;
+
+ init_error:
diff --git a/media-video/mpv/mpv-0.16.0-r1.ebuild b/media-video/mpv/mpv-0.16.0-r2.ebuild
index ca8e4a158a52..9afd78020f38 100644
--- a/media-video/mpv/mpv-0.16.0-r1.ebuild
+++ b/media-video/mpv/mpv-0.16.0-r2.ebuild
@@ -127,6 +127,7 @@ PATCHES=(
"${FILESDIR}/${P}-set-correct-seekable-flags.patch"
"${FILESDIR}/${P}-fix-bitrate-calculation.patch"
"${FILESDIR}/${P}-fix-coverart-decoding.patch"
+ "${FILESDIR}/${P}-add-missing-audio-reconfig-events.patch"
)
pkg_pretend() {