summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-09 20:16:17 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-09 20:33:49 +0100
commitc74d15941d21ebde08a06fca33119a5ba85db6c0 (patch)
treeb50b25733cc518f6271ae66258c61f487b21ae43 /media-video
parentdev-ada/asis: get rids of old style ada USE (diff)
downloadgentoo-c74d15941d21ebde08a06fca33119a5ba85db6c0.tar.gz
gentoo-c74d15941d21ebde08a06fca33119a5ba85db6c0.tar.bz2
gentoo-c74d15941d21ebde08a06fca33119a5ba85db6c0.zip
media-video/pgmfindclip: Bump to EAPI 7
Bug: https://bugs.gentoo.org/697264 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/pgmfindclip/pgmfindclip-1.13.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/media-video/pgmfindclip/pgmfindclip-1.13.ebuild b/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
index bb9f6025871d..1024f842f370 100644
--- a/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
+++ b/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
@@ -1,14 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit toolchain-funcs
-IUSE=""
-
-S="${WORKDIR}"
-
DESCRIPTION="automatically find a clipping border for a sequence of pgm images"
HOMEPAGE="http://www.lallafa.de/bp/pgmfindclip.html"
SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
@@ -16,17 +12,19 @@ SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
-src_unpack() {
- unpack ${A}
+S="${WORKDIR}"
- sed -i -e 's:gcc .* -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' "${S}"/Makefile
+src_prepare() {
+ default
+ sed -i -e 's:gcc .* -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' Makefile || die
}
-src_compile () {
- emake CC="$(tc-getCC)" || die
+src_compile() {
+ emake CC="$(tc-getCC)"
}
-src_install () {
- dobin ${PN} || die
+src_install() {
+ dobin ${PN}
}