summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2017-01-25 14:21:09 +0200
committerDavid Seifert <soap@gentoo.org>2017-01-26 23:56:03 +0100
commitc7c99395c686f50367155fdc220540f8346d3bf0 (patch)
tree302bed8e72d7ff7c1dc5d630ab7399a9261f9cdc /media-video
parentmedia-video/obs-studio: Version bump to 17.0.2. (diff)
downloadgentoo-c7c99395c686f50367155fdc220540f8346d3bf0.tar.gz
gentoo-c7c99395c686f50367155fdc220540f8346d3bf0.tar.bz2
gentoo-c7c99395c686f50367155fdc220540f8346d3bf0.zip
media-video/obs-studio: Use 'gnome2-utils' to update the icon cache.
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3643
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-studio/obs-studio-17.0.2.ebuild12
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild41
2 files changed, 34 insertions, 19 deletions
diff --git a/media-video/obs-studio/obs-studio-17.0.2.ebuild b/media-video/obs-studio/obs-studio-17.0.2.ebuild
index 2e48f5fb4ddb..5a3784f7e735 100644
--- a/media-video/obs-studio/obs-studio-17.0.2.ebuild
+++ b/media-video/obs-studio/obs-studio-17.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils gnome2-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -71,7 +71,13 @@ src_configure() {
cmake-utils_src_configure
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
+ gnome2_icon_cache_update
+
if ! use alsa && ! use pulseaudio; then
elog
elog "For the audio capture features to be available,"
@@ -98,3 +104,7 @@ pkg_postinst() {
elog
fi
}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 678d13dc8d77..51a70f595481 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="6"
+EAPI=6
-inherit cmake-utils
+inherit cmake-utils gnome2-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -52,30 +52,31 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-src_prepare() {
- CMAKE_REMOVE_MODULES_LIST=(FindFreetype)
-
- cmake-utils_src_prepare
-}
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
src_configure() {
- local libdir="$(get_libdir)"
+ local libdir=$(get_libdir)
local mycmakeargs=(
- -DDISABLE_ALSA="$(usex !alsa)"
- -DDISABLE_FREETYPE="$(usex !truetype)"
- -DDISABLE_JACK="$(usex !jack)"
- -DDISABLE_LIBFDK="$(usex !fdk)"
- -DDISABLE_PULSEAUDIO="$(usex !pulseaudio)"
- -DDISABLE_V4L2="$(usex !v4l)"
- -DLIBOBS_PREFER_IMAGEMAGICK="$(usex imagemagick)"
- -DOBS_MULTIARCH_SUFFIX="${libdir#lib}"
+ -DDISABLE_ALSA=$(usex !alsa)
+ -DDISABLE_FREETYPE=$(usex !truetype)
+ -DDISABLE_JACK=$(usex !jack)
+ -DDISABLE_LIBFDK=$(usex !fdk)
+ -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+ -DDISABLE_V4L2=$(usex !v4l)
+ -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+ -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
-DUNIX_STRUCTURE=1
)
-
cmake-utils_src_configure
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
+ gnome2_icon_cache_update
+
if ! use alsa && ! use pulseaudio; then
elog
elog "For the audio capture features to be available,"
@@ -102,3 +103,7 @@ pkg_postinst() {
elog
fi
}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}