summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-23 14:36:48 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-23 14:47:51 +0200
commitc9c05966d963947d55753a63447e8ec2c3518c3c (patch)
tree024e4eae2743528090fad3ca30ecf0d2aa863a1c /media-video
parentnet-misc/aria2: Bump to 1.24.0 (diff)
downloadgentoo-c9c05966d963947d55753a63447e8ec2c3518c3c.tar.gz
gentoo-c9c05966d963947d55753a63447e8ec2c3518c3c.tar.bz2
gentoo-c9c05966d963947d55753a63447e8ec2c3518c3c.zip
media-video/bashnapi: Bump to 1.3.5
Diffstat (limited to 'media-video')
-rw-r--r--media-video/bashnapi/Manifest1
-rw-r--r--media-video/bashnapi/bashnapi-1.3.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-video/bashnapi/Manifest b/media-video/bashnapi/Manifest
index 5d8e70316fe4..d488d36900c2 100644
--- a/media-video/bashnapi/Manifest
+++ b/media-video/bashnapi/Manifest
@@ -1 +1,2 @@
+DIST bashnapi_v1.3.5.tar.gz 98580 SHA256 a51f1c30f04bdd8fb3b267f4adbe5c8caa80e3e3320fda7d7be0a6ef5faeb961 SHA512 7cf5abb009021a43261be863f320d6324b02ea25f1388c7cc99a4f695a3eb987971ada172f74d21e3a44deeec35e48c4424fa378de53749f994b6c0d0f76eec8 WHIRLPOOL 7bd9f7d4cad694da29849fe5885b93092d35632fb41d53381c4c77efdb63bd9341a325b97900f0b638c7068e2cbaec97a481138b655413ca34ac6a8433b1b685
DIST napi_v1.1.5_subotage_0.15.tgz 38080 SHA256 7748a94bcefcbf840f4a7a13fcda2df6442de049f453baa8ff4d4158e21a47d3 SHA512 a8f2b79a3d0767c99af448e7ec9fb8d9b2048876f966ab7ef07c17b7935066387dd20e9535f43947266810d66d28e5e2d02cffc5f033c65112c10744506e86f5 WHIRLPOOL 9dd9c62dfcae68df02d022ce264030290b8d2097fbab7600770e1288c3c44321c65a54ea60e45ad8c30ce0afb8ec4b02fc8cbfdef4a62847fd821ceebf001b02
diff --git a/media-video/bashnapi/bashnapi-1.3.5.ebuild b/media-video/bashnapi/bashnapi-1.3.5.ebuild
new file mode 100644
index 000000000000..1f60c30c1b6d
--- /dev/null
+++ b/media-video/bashnapi/bashnapi-1.3.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Napiprojekt.pl subtitle downloader in bash"
+HOMEPAGE="http://sourceforge.net/projects/bashnapi/"
+SRC_URI="mirror://sourceforge/${PN}/bashnapi_v${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# subotage is now integrated into bashnapi
+RDEPEND="app-arch/p7zip
+ !media-video/subotage"
+
+S=${WORKDIR}/napi-${PV}
+
+src_configure() {
+ # install.sh does not support --destdir
+ sed -i -e "s^\(NAPI_COMMON_PATH=\).*$^\1${EPREFIX}/usr/share/napi^" \
+ napi.sh subotage.sh || die
+}
+
+src_install() {
+ default # for docs
+ dobin napi.sh subotage.sh
+ insinto /usr/share/napi
+ doins napi_common.sh
+}
+
+pkg_postinst() {
+ # packages that can be used to detect FPS
+ local fps_pkgs=(
+ media-video/ffmpeg
+ media-video/mediainfo
+ media-video/mplayer
+ # also mplayer2
+ )
+ local p found
+
+ for p in "${fps_pkgs[@]}"; do
+ if has_version "${p}"; then
+ found=1
+ break
+ fi
+ done
+
+ if [[ ! ${found} ]]; then
+ elog "In order to support FPS detection, install one of the following packages:"
+ elog
+ for p in "${fps_pkgs[@]}"; do
+ elog " ${p}"
+ done
+ fi
+}