summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-01 23:05:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-01 23:14:40 +0100
commitdde76760be43f6c85fe03ace42ccc47faf01b49b (patch)
tree3b083fa9aa536c5adfdc4b3ca2e6255d387a440c /media-video
parentx11-plugins/wminet: fix build with -fno-common (diff)
downloadgentoo-dde76760be43f6c85fe03ace42ccc47faf01b49b.tar.gz
gentoo-dde76760be43f6c85fe03ace42ccc47faf01b49b.tar.bz2
gentoo-dde76760be43f6c85fe03ace42ccc47faf01b49b.zip
media-video/openshot: 2.5.1_p20201227 snapshot bump
Bug: https://bugs.gentoo.org/709858 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/openshot/Manifest1
-rw-r--r--media-video/openshot/openshot-2.5.1_p20201227.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
index f08226a58cba..d720a147fada 100644
--- a/media-video/openshot/Manifest
+++ b/media-video/openshot/Manifest
@@ -2,3 +2,4 @@ DIST openshot-2.4.4.tar.gz 63065376 BLAKE2B 2ee00f24d699d5935a182c394821f215a27b
DIST openshot-2.5.0.tar.gz 60153193 BLAKE2B cdc79c68be7cd5b9e2714c98c4edbb5fc9ec349283da8439e9f9e26b2341688e2b8ae0f108413f59582d6e447faeb96d1da6916503299ca40939d73f5983377f SHA512 0944bff48c8957a4a3c5a37428b4d3e45e8ad6e1664812ea90b7c16d014a3c355daf2fe183ce855586114ccfa36c419b6baacc42c4bf871de29bda4c24f2a814
DIST openshot-2.5.1.tar.gz 60217543 BLAKE2B 3f195b14a9fb004e845c731be64138c20da84ac0c90db43b547ee9ea059d32f85ada04aa0462b755a7ea5c3d3b30088fab35414147dded55deb9d5eab5926d2d SHA512 8254a45254bbe523b6485b9598022de2c46ec30818e606ac4665790d29486693c4efe9f5bc55ee43d6342de6782cf0090e4bc880e831c08e3b1218bca555af14
DIST openshot-2.5.1_p20201203.tar.gz 64708017 BLAKE2B b95834b8b75460b60a54b2c1efab1752424c291f5e16fefd33671f7ea9eb9c29d48047a18287a9cf2837c21e3c1ea9a7217fcbdc27440bacc04ff6f8da6202a2 SHA512 668c3155489d469042220e059cb0fc4de50b4d949c28d4ae6e8ef9b6ccdd3235dd4912b5163ae4126758621052d4b40f21aa40c6e1682776a71076f0c45cbcdc
+DIST openshot-2.5.1_p20201227.tar.gz 64708834 BLAKE2B 7b8742eae1865fe510d1690eb1df907ba4e5079093af075308a17304ea184976df064b6065fab6ef2394efbad2e0042174145ea9cd7213e6d8993bf30a865c81 SHA512 3688bee7a7febfbb12351e0bcceb9831c778bec3ae441cc9b10fc01e695747cf20912ceee54a275a956c443aaf1c4fcb0cd6b54f10474e6e95d025685d0bd4bd
diff --git a/media-video/openshot/openshot-2.5.1_p20201227.ebuild b/media-video/openshot/openshot-2.5.1_p20201227.ebuild
new file mode 100644
index 000000000000..97eb2a8c185e
--- /dev/null
+++ b/media-video/openshot/openshot-2.5.1_p20201227.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE=xml
+DISTUTILS_SINGLE_IMPL=1
+
+COMMIT=5056d240c5dff1a9191ca2e0f7a8813c57b5b5ca
+MY_PN="${PN}-qt"
+inherit distutils-r1 xdg
+
+DESCRIPTION="Award-winning free and open-source video editor"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="1"
+# KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,svg,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyzmq[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=media-libs/libopenshot-0.2.5:0=[python,${PYTHON_SINGLE_USEDEP}]
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ doc? ( dev-python/sphinx[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # prevent setup.py from trying to update MIME databases
+ sed -i 's/^ROOT =.*/ROOT = False/' setup.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}