summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-16 21:22:15 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-16 21:28:19 -0700
commitedaaba4ba6f7f9369ea53743cbe5857ce0b8bd85 (patch)
tree2866b6fa8c2eb7e45e54a88aa61e3fe91271003a /media-video
parentmedia-video/libva-utils: Switch to Meson (diff)
downloadgentoo-edaaba4ba6f7f9369ea53743cbe5857ce0b8bd85.tar.gz
gentoo-edaaba4ba6f7f9369ea53743cbe5857ce0b8bd85.tar.bz2
gentoo-edaaba4ba6f7f9369ea53743cbe5857ce0b8bd85.zip
media-video/libva-utils: Version bump to 2.14.0
Closes: https://github.com/gentoo/gentoo/pull/24410 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libva-utils/Manifest1
-rw-r--r--media-video/libva-utils/libva-utils-2.14.0.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/media-video/libva-utils/Manifest b/media-video/libva-utils/Manifest
index 7a0b875bbf18..e8953d2e4dc7 100644
--- a/media-video/libva-utils/Manifest
+++ b/media-video/libva-utils/Manifest
@@ -1 +1,2 @@
DIST libva-utils-2.13.0.tar.gz 1230036 BLAKE2B 4e70a13fb9b4362713b6f461a0ee199b8f7e9d9cbac7bc664c11870db92a87873d73306b5777c554830b932a15e726965e1db3591fd1349fb62f068617dd8558 SHA512 81c7c122a4d1bdf8d390a4ea3e0d34499158fb7b7fe0f7aa9d556158895e755139975fd01d73d883897c0a4390612d131b6349febbdf16fa5edcd46a6a82acd2
+DIST libva-utils-2.14.0.tar.gz 1241072 BLAKE2B 17f1e0badb05e39f3979bde652dfe6832e8bfb2accd99fd6c5d972090cfce630e2a93ad96e5d17bc7bd9c393b12c2a7b066cb60a715c2dbb128dd263c480bcca SHA512 631e9becf5b2f6d083906962c004c9080d2e2b2d98b6003638a31dde8ad4e2549606301b97e88822471e29007232fc470a2116be09dc0c55d3cc2df6a45a7be1
diff --git a/media-video/libva-utils/libva-utils-2.14.0.ebuild b/media-video/libva-utils/libva-utils-2.14.0.ebuild
new file mode 100644
index 000000000000..4decf846c639
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-2.14.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+else
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples putsurface test +vainfo wayland X"
+RESTRICT="test" # Tests must be run manually
+
+REQUIRED_USE="
+ putsurface? ( || ( wayland X ) )
+ || ( examples putsurface test vainfo )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} = *9999 ]] ; then
+ DEPEND="~x11-libs/libva-${PV}:=[drm(+),wayland?,X?]"
+else
+ DEPEND=">=x11-libs/libva-$(ver_cut 1-2).0:=[drm(+),wayland?,X?]"
+fi
+
+DEPEND+="
+ wayland? ( >=dev-libs/wayland-1.0.6 )
+ X? ( >=x11-libs/libX11-1.6.2 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ local sed_args=()
+
+ # Fix broken dependency check
+ # https://github.com/intel/libva-utils/pull/260
+ sed_args+=(-e "s/dependency('drm'/dependency('libdrm'/")
+
+ if ! use examples ; then
+ sed_args+=(
+ -e "/^subdir('decode')$/d"
+ -e "/^subdir('encode')$/d"
+ -e "/^subdir('videoprocess')$/d"
+ -e "/^subdir('vendor\/intel')$/d"
+ -e "/^subdir('vendor\/intel\/sfcsample')$/d"
+ )
+ fi
+
+ if ! use putsurface ; then
+ sed_args+=(-e "/^subdir('putsurface')$/d")
+ fi
+
+ if ! use vainfo ; then
+ sed_args+=(-e "/^subdir('vainfo')$/d")
+ fi
+
+ if [[ ${#sed_args[@]} -gt 0 ]] ; then
+ sed "${sed_args[@]}" -i meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddrm=true
+ $(meson_use X x11)
+ $(meson_use wayland)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use test ; then
+ rm -f "${ED}"/usr/bin/test_va_api || die
+ fi
+}
+
+pkg_postinst() {
+ if use test ; then
+ elog "Tests must be run manually with the test_va_api binary"
+ fi
+}