summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-08 11:27:10 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-08 11:32:27 +0100
commit9007ea9ed20c439028fb059dffd77163fb3c5b14 (patch)
tree87522da7d5002609d3b59cb5c312fbbf876b7737 /net-analyzer/amap/amap-5.4-r1.ebuild
parentx11-terms/st: add 0.8.5 (diff)
downloadgentoo-9007ea9ed20c439028fb059dffd77163fb3c5b14.tar.gz
gentoo-9007ea9ed20c439028fb059dffd77163fb3c5b14.tar.bz2
gentoo-9007ea9ed20c439028fb059dffd77163fb3c5b14.zip
net-analyzer/amap: treeclean
Closes: https://bugs.gentoo.org/680546 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-analyzer/amap/amap-5.4-r1.ebuild')
-rw-r--r--net-analyzer/amap/amap-5.4-r1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/net-analyzer/amap/amap-5.4-r1.ebuild b/net-analyzer/amap/amap-5.4-r1.ebuild
deleted file mode 100644
index 17fd129b9fa7..000000000000
--- a/net-analyzer/amap/amap-5.4-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="A network scanning tool for pentesters"
-HOMEPAGE="https://www.thc.org/thc-amap/"
-SRC_URI="https://www.thc.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="ssl"
-
-DEPEND="
- dev-libs/libpcre
- ssl? ( dev-libs/openssl:0= )
-"
-RDEPEND="
- ${DEPEND}
- !sci-biology/amap
-"
-
-PATCHES=(
- "${FILESDIR}"/4.8-system-pcre.patch
-)
-
-src_prepare() {
- rm -r pcre-3.9 || die
-
- sed -i -e "s:etc/:share/amap/:g" amap-lib.c || die
-
- # Above change requires below change. See sources...
- sed -i '/strlen(AMAP_PREFIX/s: 5 : 12 :' amap-lib.c || die
- sed -i 's:/usr/local:/usr:' amap.h || die
-
- # Files to be updated are at different location, bug 207839.
- sed -i '/AMAP_RESOURCE/s:www:freeworld:' amap.h || die
-
- sed -i '/DATADIR/s:/etc:/share/amap:' Makefile.am || die
-
- default
-}
-
-src_configure() {
- # non-autotools configure script
- ./configure || die
-
- sed -i \
- -e '/^XDEFINES=/s:=.*:=:' \
- -e '/^XLIBS=/s:=.*:=:' \
- -e '/^XLIBPATHS/s:=.*:=:' \
- -e '/^XIPATHS=/s:=.*:=:' \
- -e "/^CC=/d" \
- Makefile || die
-
- if use ssl ; then
- sed -i \
- -e '/^XDEFINES=/s:=:=-DOPENSSL:' \
- -e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
- Makefile || die
- fi
-
- sed -i Makefile \
- -e '/-o amap/{s|(OPT) |(OPT) $(LDFLAGS) |g}' \
- || die
-}
-
-src_compile() {
- emake CC=$(tc-getCC) OPT="${CFLAGS}"
-}
-
-src_install() {
- dobin amap amapcrap
- insinto /usr/share/amap
- doins appdefs.*
-
- doman ${PN}.1
- dodoc README TODO CHANGES
-}