summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-11-10 06:21:22 +0100
committerJeroen Roovers <jer@gentoo.org>2015-11-10 06:21:57 +0100
commit4152574fcb98b57c075c18b9d89cae3007c9ce20 (patch)
treedee387c15d5f9930c573865554c9ca2a8e14bcb5 /net-analyzer/arping
parentsci-mathematics/maxima: cleaning 5.37.2 (diff)
downloadgentoo-4152574fcb98b57c075c18b9d89cae3007c9ce20.tar.gz
gentoo-4152574fcb98b57c075c18b9d89cae3007c9ce20.tar.bz2
gentoo-4152574fcb98b57c075c18b9d89cae3007c9ce20.zip
net-analyzer/arping: Add USE=filecaps (bug #564906 by Nick Kossifidis).
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-analyzer/arping')
-rw-r--r--net-analyzer/arping/arping-2.15-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.15-r3.ebuild b/net-analyzer/arping/arping-2.15-r3.ebuild
new file mode 100644
index 000000000000..8ede2e3685d3
--- /dev/null
+++ b/net-analyzer/arping/arping-2.15-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils fcaps
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+"
+RDEPEND="
+ ${DEPEND}
+ !net-misc/iputils[arping(+)]
+"
+
+FILECAPS=( cap_net_raw /usr/sbin/arping )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.15-setgroups.patch
+
+ eautoreconf
+}