summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-12-06 10:49:27 +0100
committerJeroen Roovers <jer@gentoo.org>2017-12-06 10:49:27 +0100
commitf9ae1349917b09afbee6f84f92349200f90938ca (patch)
tree7db45207b6b4c162736a980b0926514aad8d9136 /net-analyzer/cacti-spine/cacti-spine-1.1.28.ebuild
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-f9ae1349917b09afbee6f84f92349200f90938ca.tar.gz
gentoo-f9ae1349917b09afbee6f84f92349200f90938ca.tar.bz2
gentoo-f9ae1349917b09afbee6f84f92349200f90938ca.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/cacti-spine/cacti-spine-1.1.28.ebuild')
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.1.28.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.1.28.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.1.28.ebuild
new file mode 100644
index 000000000000..d148f4544d01
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.1.28.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}