summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/calamaris
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/calamaris')
-rw-r--r--net-analyzer/calamaris/Manifest2
-rw-r--r--net-analyzer/calamaris/calamaris-2.59.ebuild21
-rw-r--r--net-analyzer/calamaris/calamaris-2.99.4.0.ebuild35
-rw-r--r--net-analyzer/calamaris/metadata.xml6
4 files changed, 64 insertions, 0 deletions
diff --git a/net-analyzer/calamaris/Manifest b/net-analyzer/calamaris/Manifest
new file mode 100644
index 000000000000..9f600e71bd8f
--- /dev/null
+++ b/net-analyzer/calamaris/Manifest
@@ -0,0 +1,2 @@
+DIST calamaris-2.59.tar.gz 56168 SHA256 60103bf6bfe0142bf2a0dfa7f7647ae7ed739b8b3082f11b8e55e21c2546d7ae SHA512 8c8ed820a1af6e21cfe9f03397c159b2261c8253b3395a8d6dbd21064151439406496132917d0ef087eed805c7945cf28f2d12dc1e52340991c18e6a27484ade WHIRLPOOL ff8bf09664d52a65629747431ed89955882c2ec7ee33e75cfeedcfc39cb776670b3ed874e063e4727157b17e212e5fbf08c311caa29967e7f0b3cdcea9118b63
+DIST calamaris-2.99.4.0.tar.gz 105860 SHA256 a28333ed770996397cc752e813586ac9177aab5c9dfee0104133d9c2c7dea42c SHA512 4127a3963fd0ea5baa1d5ce9a784f45658bb685f18e576c134fee1b4e8fdad535676974498119018e771924a8a622ed83b8aa095d3909b7bb3d009dd6024dbef WHIRLPOOL c5b9d9294937496d99abe7e1dd3eca7636f008847d55e5ab74c0d9a644a842ef88c9c11102fbb31a3c42d34d0fdcdff14f1740f9a3f0bed5f0479e655d6a601c
diff --git a/net-analyzer/calamaris/calamaris-2.59.ebuild b/net-analyzer/calamaris/calamaris-2.59.ebuild
new file mode 100644
index 000000000000..f22d3d876e0f
--- /dev/null
+++ b/net-analyzer/calamaris/calamaris-2.59.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Calamaris parses the logfiles of a wide variety of Web proxy servers and generates reports"
+HOMEPAGE="http://cord.de/calamaris-home-page"
+SRC_URI="http://cord.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="dev-lang/perl"
+
+src_install () {
+ dobin calamaris
+ doman calamaris.1
+ dodoc CHANGES EXAMPLES README
+}
diff --git a/net-analyzer/calamaris/calamaris-2.99.4.0.ebuild b/net-analyzer/calamaris/calamaris-2.99.4.0.ebuild
new file mode 100644
index 000000000000..dd0778225298
--- /dev/null
+++ b/net-analyzer/calamaris/calamaris-2.99.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Calamaris parses the logfiles of a wide variety of Web proxy servers and generates reports"
+HOMEPAGE="http://cord.de/calamaris-home-page"
+SRC_URI="http://cord.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/GDGraph
+"
+
+src_prepare() {
+ sed -i \
+ -e "s:\(use lib\).*$:\1 '/usr/share/';:" \
+ calamaris || die
+}
+
+src_install() {
+ dobin calamaris calamaris-cache-convert
+
+ insinto /usr/share/${PN}
+ doins *.pm
+
+ doman calamaris.1
+
+ dodoc BUGS CHANGES EXAMPLES EXAMPLES.v3 README TODO calamaris.conf
+}
diff --git a/net-analyzer/calamaris/metadata.xml b/net-analyzer/calamaris/metadata.xml
new file mode 100644
index 000000000000..e0a1efa4d101
--- /dev/null
+++ b/net-analyzer/calamaris/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>Calamaris parses the logfiles of a wide variety of Web proxy servers and generates reports</longdescription>
+</pkgmetadata>