summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cnet/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cnet/files')
-rw-r--r--net-analyzer/cnet/files/cnet-3.3.1-gentoo.patch163
-rw-r--r--net-analyzer/cnet/files/cnet-3.3.1-tcl.patch13
2 files changed, 176 insertions, 0 deletions
diff --git a/net-analyzer/cnet/files/cnet-3.3.1-gentoo.patch b/net-analyzer/cnet/files/cnet-3.3.1-gentoo.patch
new file mode 100644
index 000000000000..9754fb4ebf84
--- /dev/null
+++ b/net-analyzer/cnet/files/cnet-3.3.1-gentoo.patch
@@ -0,0 +1,163 @@
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@
+ # Comment/uncomment the following 4 constants to suit your system:
+ #
+ # PREFIX defines the directory below which cnet will be installed.
+-PREFIX = /usr/local
++PREFIX = /usr
+ #PREFIX = $(HOME)
+ #
+ # BINDIR defines the directory where the cnet binary will be installed.
+@@ -16,26 +16,24 @@
+ LIBDIR = $(PREFIX)/lib64/cnet
+ #
+ # WWWDIR defines the directory to hold cnet's web-based documentation
+-WWWDIR = /home/httpd/html/cnet
++#WWWDIR = /home/httpd/html/cnet
+ #WWWDIR = $(HOME)/WWW/cnet
+ #
+ # ---------------------------------------------------------------------
+ #
+ it:
+- make -C src
+- make -C support
++ $(MAKE) -C src
++ $(MAKE) -C support
+ @ls -l bin/$(NAME) lib/*.a
+
+ install:
+- make
+- @mkdir -p $(BINDIR) $(LIBDIR)
+- @chmod 755 $(BINDIR) $(LIBDIR)
+- @cp bin/$(NAME) $(BINDIR)/$(NAME)
+- @chmod 755 $(BINDIR)/$(NAME)
+- @rm -rf $(LIBDIR)/*
+- @cp lib/* $(LIBDIR)
+- @chmod 644 $(LIBDIR)/*
+- @ls -l $(BINDIR)/$(NAME) $(LIBDIR)/*.a
++ @mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR)
++ @chmod 755 $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR)
++ @cp bin/$(NAME) $(DESTDIR)$(BINDIR)/$(NAME)
++ @chmod 755 $(DESTDIR)$(BINDIR)/$(NAME)
++ @rm -rf $(DESTDIR)$(LIBDIR)/*
++ @cp lib/* $(DESTDIR)$(LIBDIR)
++ @chmod 644 $(DESTDIR)$(LIBDIR)/*
+
+ AND = html/CLICK html/KEYBOARD html/STOPANDWAIT html/TICKTOCK
+ www:
+--- a/src/Makefile.linux
++++ b/src/Makefile.linux
+@@ -5,7 +5,7 @@
+ # binutils 2.5.2, and
+ # libelf (0.6.4 onwards)
+ #
+-WARNINGS = -Wall -Werror -Wshadow -Wpointer-arith -Wcast-qual \
++WARNINGS = -Wall -Wshadow -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings -Wconversion \
+ -Wstrict-prototypes -Wredundant-decls -Winline \
+ -Wcomments -Wtrigraphs -Wimport -Wundef
+@@ -20,8 +20,8 @@
+ XINCLUDES = -I/usr/include/tcl8.5
+ XLIBS = -ltcl8.5 -ltk8.5 -lX11
+ #
+-C99 = gcc -std=c99 -Wall -Werror -pedantic
+-CFLAGS = -O3 -fPIC $(INCLUDES) $(XINCLUDES)
++C99 = $(CC) -std=c99 -Wall -pedantic
++CFLAGS += -fPIC $(INCLUDES) $(XINCLUDES)
+ #
+ LD = gcc -rdynamic
+ LIBDIRS = $(XLIBDIRS)
+--- a/support/Makefile
++++ b/support/Makefile
+@@ -7,21 +7,21 @@
+
+ it:
+ @if uname -s -r | grep -q "Linux" ; then \
+- make -f Makefile.linux ; fi
++ $(MAKE) -f Makefile.linux ; fi
+ @if uname -s -r | grep -q "Darwin" ; then \
+- make -f Makefile.macosx ; fi
++ $(MAKE) -f Makefile.macosx ; fi
+ @if uname -s -r | grep -q "SunOS 4" ; then \
+- make -f Makefile.sunos ; fi
++ $(MAKE) -f Makefile.sunos ; fi
+ @if uname -s -r | grep -q "SunOS 5" ; then \
+- make -f Makefile.solaris ; fi
++ $(MAKE) -f Makefile.solaris ; fi
+ @if uname -s -r | grep -q "OSF1" ; then \
+- make -f Makefile.osf1 ; fi
++ $(MAKE) -f Makefile.osf1 ; fi
+ @if uname -s -r | grep -q "IRIX" ; then \
+- make -f Makefile.irix5 ; fi
++ $(MAKE) -f Makefile.irix5 ; fi
+ @if uname -s -r | grep -q "FreeBSD" ; then \
+- make -f Makefile.freebsd ; fi
++ $(MAKE) -f Makefile.freebsd ; fi
+ @if uname -s -r | grep -q "NetBSD" ; then \
+- make -f Makefile.netbsd ; fi
++ $(MAKE) -f Makefile.netbsd ; fi
+ @cp -p cnetsupport.h ../lib
+
+ # ---------------------------------------------------------------------
+--- a/support/Makefile.common
++++ b/support/Makefile.common
+@@ -1,13 +1,13 @@
+ #
+-CC = gcc
+-CFLAGS = -std=c99 -pedantic -Wall -Werror -O3 -fPIC
++#CC = gcc
++CFLAGS += -std=c99 -pedantic -Wall -fPIC
+
+ DOTH = cnetsupport.h
+ OBJ = hashtable.o haversine.o lexical.o md5.o queue.o vector.o
+
+ $(NAME): $(OBJ)
+- ar rc $(NAME) $(OBJ)
+- ranlib $(NAME)
++ $(AR) rc $(NAME) $(OBJ)
++ $(RANLIB) $(NAME)
+ @cp -p $(NAME) ../lib
+
+ %.o : %.c $(DOTH)
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -8,21 +8,21 @@
+
+ it:
+ @if uname -s -r | grep -q "Linux" ; then \
+- make -f Makefile.linux $(NAME) ; fi
++ $(MAKE) -f Makefile.linux $(NAME) ; fi
+ @if uname -s -r | grep -q "Darwin" ; then \
+- make -f Makefile.macosx $(NAME) ; fi
++ $(MAKE) -f Makefile.macosx $(NAME) ; fi
+ @if uname -s -r | grep -q "SunOS 4" ; then \
+- make -f Makefile.sunos $(NAME) ; fi
++ $(MAKE) -f Makefile.sunos $(NAME) ; fi
+ @if uname -s -r | grep -q "SunOS 5" ; then \
+- make -f Makefile.solaris $(NAME) ; fi
++ $(MAKE) -f Makefile.solaris $(NAME) ; fi
+ @if uname -s -r | grep -q "OSF1" ; then \
+- make -f Makefile.osf1 $(NAME) ; fi
++ $(MAKE) -f Makefile.osf1 $(NAME) ; fi
+ @if uname -s -r | grep -q "IRIX" ; then \
+- make -f Makefile.irix5 $(NAME) ; fi
++ $(MAKE) -f Makefile.irix5 $(NAME) ; fi
+ @if uname -s -r | grep -q "FreeBSD" ; then \
+- make -f Makefile.freebsd $(NAME) ; fi
++ $(MAKE) -f Makefile.freebsd $(NAME) ; fi
+ @if uname -s -r | grep -q "NetBSD" ; then \
+- make -f Makefile.netbsd $(NAME) ; fi
++ $(MAKE) -f Makefile.netbsd $(NAME) ; fi
+ @cp -p $(NAME) ../bin
+ @cp -p cnet.h ../lib
+
+@@ -33,7 +33,7 @@
+ @rm -rf HTML GPATH GRTAGS GSYMS GTAGS
+
+ hide:
+- make clean
++ $(MAKE) clean
+ echo '#if HIDE_GLOBAL_NAMES' > hidenames.h
+ sort < HIDENAMES | \
+ awk '{ if($$0 !~ /#/) printf("#define\t%-36s\t__CN%03d\n", $$0,++n);}'\
diff --git a/net-analyzer/cnet/files/cnet-3.3.1-tcl.patch b/net-analyzer/cnet/files/cnet-3.3.1-tcl.patch
new file mode 100644
index 000000000000..4c30673f2e67
--- /dev/null
+++ b/net-analyzer/cnet/files/cnet-3.3.1-tcl.patch
@@ -0,0 +1,13 @@
+--- a/src/Makefile.linux
++++ b/src/Makefile.linux
+@@ -17,8 +17,8 @@
+ #XLIBS = -ltcl -ltk -lX11
+ #
+ # or you may need something like:
+-XINCLUDES = -I/usr/include/tcl8.5
+-XLIBS = -ltcl8.5 -ltk8.5 -lX11
++#XINCLUDES = -I/usr/include/tcl8.5
++XLIBS = -ltcl -ltk -lX11
+ #
+ C99 = $(CC) -std=c99 -Wall -pedantic
+ CFLAGS += -fPIC $(INCLUDES) $(XINCLUDES)