summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-01-24 10:29:26 +0100
committerJeroen Roovers <jer@gentoo.org>2016-01-24 10:29:43 +0100
commit3f16d8f3bcd465ac83a2df982070f8653012d654 (patch)
treebece8761de077688fcbe7f5e68b3b59bd66dd5d9 /net-analyzer/dosdetector/dosdetector-20060621-r1.ebuild
parentmedia-video/vlc: Update 9999. Fix bug #571568, add chromecast, restrict ffmpeg (diff)
downloadgentoo-3f16d8f3bcd465ac83a2df982070f8653012d654.tar.gz
gentoo-3f16d8f3bcd465ac83a2df982070f8653012d654.tar.bz2
gentoo-3f16d8f3bcd465ac83a2df982070f8653012d654.zip
net-analyzer/dosdetector: Drop bzero calls with wrong size argument since calloc will do the zeroing anyway.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer/dosdetector/dosdetector-20060621-r1.ebuild')
-rw-r--r--net-analyzer/dosdetector/dosdetector-20060621-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-analyzer/dosdetector/dosdetector-20060621-r1.ebuild b/net-analyzer/dosdetector/dosdetector-20060621-r1.ebuild
new file mode 100644
index 000000000000..ba113ec6cd71
--- /dev/null
+++ b/net-analyzer/dosdetector/dosdetector-20060621-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Tool to analyze and detect suspicious traffic from IP and alert about it"
+HOMEPAGE="http://dark-zone.eu/resources/unix/dosdetector/"
+SRC_URI="http://dark-zone.eu/resources/unix/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-isdigit.patch \
+ "${FILESDIR}"/${P}-sizeof.patch
+}