summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/egressor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/egressor')
-rw-r--r--net-analyzer/egressor/Manifest1
-rw-r--r--net-analyzer/egressor/egressor-1.0-r2.ebuild38
-rw-r--r--net-analyzer/egressor/files/1.0-flags.patch22
-rw-r--r--net-analyzer/egressor/files/1.0-libnet-1.0.patch10
-rw-r--r--net-analyzer/egressor/metadata.xml6
5 files changed, 77 insertions, 0 deletions
diff --git a/net-analyzer/egressor/Manifest b/net-analyzer/egressor/Manifest
new file mode 100644
index 000000000000..0e1ccc36081b
--- /dev/null
+++ b/net-analyzer/egressor/Manifest
@@ -0,0 +1 @@
+DIST egressor_release1.0.tar.gz 28746 SHA256 3608ae0d76f76513318ce57fe986936ec890650cb311762b374f463ffd898fba SHA512 dfb1ee553ccfb92429fe68df06db031e5cbca41fe4fda36961ba8121d79de03a7dc36febc5a58561c3de9b1412cc90811f5ddc8b156aab8282b0dc3c14cd7aec WHIRLPOOL e2307f897e6b0c0f813577f6c367285b61ee8204acc51db4bccf3f4133bdc0044c27e6b3057cdc9d7f93d271c22d0251e3fdd1dd780d9811c344dbde75320fe6
diff --git a/net-analyzer/egressor/egressor-1.0-r2.ebuild b/net-analyzer/egressor/egressor-1.0-r2.ebuild
new file mode 100644
index 000000000000..386c85fdc60b
--- /dev/null
+++ b/net-analyzer/egressor/egressor-1.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tool for checking router configuration"
+HOMEPAGE="http://packetfactory.openwall.net/projects/egressor/"
+SRC_URI="${HOMEPAGE}${PN}_release${PV}.tar.gz"
+
+LICENSE="egressor"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="<net-libs/libnet-1.1
+ >=net-libs/libnet-1.0.2a-r3"
+RDEPEND="net-libs/libpcap
+ dev-perl/Net-RawIP
+ dev-lang/perl"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-libnet-1.0.patch \
+ "${FILESDIR}"/${PV}-flags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake -C client
+}
+
+src_install() {
+ dobin client/egressor server/egressor_server.pl
+ dodoc README client/README-CLIENT server/README-SERVER
+}
diff --git a/net-analyzer/egressor/files/1.0-flags.patch b/net-analyzer/egressor/files/1.0-flags.patch
new file mode 100644
index 000000000000..03368b05dbaa
--- /dev/null
+++ b/net-analyzer/egressor/files/1.0-flags.patch
@@ -0,0 +1,22 @@
+--- a/client/Makefile
++++ b/client/Makefile
+@@ -5,8 +5,8 @@
+ #----------------------------------------------------------------------
+
+
+-CC = gcc
+-CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -Wall -DMD=5
++CC ?= gcc
++CFLAGS += -Wall -DMD=5
+ #CFLAGS2 = -O -DMD=5
+ OBJECTS = egressor.o md5c.o \
+
+@@ -21,7 +21,7 @@
+
+
+ egressor: egressor.o md5c.o
+- $(CC) egressor.o $(LIBS) -o ./egressor
++ $(CC) $(CFLAGS) $(LDFLAGS) egressor.o $(LIBS) -o ./egressor
+
+ md5c.o: global.h md5.h
+ $(CC) -c $(CFLAGS) md5c.c
diff --git a/net-analyzer/egressor/files/1.0-libnet-1.0.patch b/net-analyzer/egressor/files/1.0-libnet-1.0.patch
new file mode 100644
index 000000000000..be7cb4f15c6f
--- /dev/null
+++ b/net-analyzer/egressor/files/1.0-libnet-1.0.patch
@@ -0,0 +1,10 @@
+--- a/client/Makefile
++++ b/client/Makefile
+@@ -15 +15 @@
+-LIBS = -L../../lib/ -lnet
++LIBS = -L../../lib/ -lnet-1.0
+--- a/client/libnet_test.h
++++ b/client/libnet_test.h
+@@ -36 +36 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
diff --git a/net-analyzer/egressor/metadata.xml b/net-analyzer/egressor/metadata.xml
new file mode 100644
index 000000000000..b54ba29ed2df
--- /dev/null
+++ b/net-analyzer/egressor/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>tool for checking router configuration</longdescription>
+</pkgmetadata>