summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:32 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:32 +0100
commit73bca9b839ec8c3d5b73bdebd0791265884f4fe4 (patch)
tree169003ef1c0bf0de6204e6a55dda8925c8597530 /net-analyzer/fail2ban
parentmedia-sound/pulseaudio: migrate to tmpfiles.eclass (diff)
downloadgentoo-73bca9b839ec8c3d5b73bdebd0791265884f4fe4.tar.gz
gentoo-73bca9b839ec8c3d5b73bdebd0791265884f4fe4.tar.bz2
gentoo-73bca9b839ec8c3d5b73bdebd0791265884f4fe4.zip
net-analyzer/fail2ban: migrate to tmpfiles.eclass
Closes: https://bugs.gentoo.org/740616 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.11.2.ebuild6
-rw-r--r--net-analyzer/fail2ban/fail2ban-9999.ebuild4
2 files changed, 5 insertions, 5 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
index bd350a8ac577..5ed0a845c74d 100644
--- a/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_SINGLE_IMPL=1
-inherit bash-completion-r1 distutils-r1 systemd
+inherit bash-completion-r1 distutils-r1 systemd tmpfiles
DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
@@ -58,7 +58,7 @@ python_install_all() {
newinitd files/gentoo-initd ${PN}
sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
systemd_dounit "${T}/${PN}.service"
- systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ dotmpfiles files/${PN}-tmpfiles.conf
doman man/*.{1,5}
# Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
diff --git a/net-analyzer/fail2ban/fail2ban-9999.ebuild b/net-analyzer/fail2ban/fail2ban-9999.ebuild
index ee45ceced90c..5e5fb78a51f6 100644
--- a/net-analyzer/fail2ban/fail2ban-9999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_SINGLE_IMPL=1
-inherit bash-completion-r1 distutils-r1 git-r3 systemd
+inherit bash-completion-r1 distutils-r1 git-r3 systemd tmpfiles
DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="https://www.fail2ban.org/"
@@ -58,7 +58,7 @@ python_install_all() {
newinitd files/gentoo-initd ${PN}
sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
systemd_dounit "${T}/${PN}.service"
- systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ dotmpfiles files/${PN}-tmpfiles.conf
doman man/*.{1,5}
# Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.