summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-01 07:18:43 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-01 07:19:11 +0100
commitd3634f6c31c170dcab9cadbec7f502b10c2b1a70 (patch)
tree10fc6650e1d232b89208c39e75c5d81fb8597d46 /net-analyzer/fail2ban
parentnet-analyzer/fail2ban: Fix live ebuild (diff)
downloadgentoo-d3634f6c31c170dcab9cadbec7f502b10c2b1a70.tar.gz
gentoo-d3634f6c31c170dcab9cadbec7f502b10c2b1a70.tar.bz2
gentoo-d3634f6c31c170dcab9cadbec7f502b10c2b1a70.zip
net-analyzer/fail2ban: Old
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/Manifest1
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.10.3.1.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/net-analyzer/fail2ban/Manifest b/net-analyzer/fail2ban/Manifest
index 29d56938a6cc..8ae35bf67015 100644
--- a/net-analyzer/fail2ban/Manifest
+++ b/net-analyzer/fail2ban/Manifest
@@ -1,2 +1 @@
-DIST fail2ban-0.10.3.1.tar.gz 485826 BLAKE2B 79ca86a601bd79ba3729d4c9b00f20a0717df8c7ceb20183099e11f84cceade274173be90d0b4b000d37a1b9d242e14106c9e7e40e372e450d69bca003fff6fb SHA512 ed3646ef2113fe10d9130c239818087b228ac9708411e26acc412beae022e3f9ff8cea32d824bd491117882fb8f184dcb88bda295bd31e865ac8310c7e27fc7a
DIST fail2ban-0.10.4.tar.gz 493104 BLAKE2B 3a58ab114cf25172c77b229ce53bf6dd009d4fb8c700142480ba0212072d8820126bfabf5dd417835bdac5f5b65d599c6dde859d8c57267e90cfb569dc4a2073 SHA512 ee53f2e8dc3cda4f588c60da5227d3d71550496ddfdf5bdbffced25bafd442b8e2352a9ad9f27bf76489903b5b779cdb9614963342de907c1036ae9268b8f35f
diff --git a/net-analyzer/fail2ban/fail2ban-0.10.3.1.ebuild b/net-analyzer/fail2ban/fail2ban-0.10.3.1.ebuild
deleted file mode 100644
index 3dda24f6f476..000000000000
--- a/net-analyzer/fail2ban/fail2ban-0.10.3.1.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 eutils systemd vcs-snapshot
-
-DESCRIPTION="scans log files and bans IPs that show malicious signs"
-HOMEPAGE="http://www.fail2ban.org/"
-SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="selinux systemd"
-
-# TODO support ipfw and ipfilter
-RDEPEND="
- kernel_linux? ( net-firewall/iptables )
- kernel_FreeBSD? ( sys-freebsd/freebsd-pf )
- net-misc/whois
- virtual/logger
- virtual/mta
- selinux? ( sec-policy/selinux-fail2ban )
- systemd? ( $(python_gen_cond_dep '|| (
- dev-python/python-systemd[${PYTHON_USEDEP}]
- sys-apps/systemd[python(-),${PYTHON_USEDEP}]
- )' 'python*' ) )
-"
-
-REQUIRED_USE="systemd? ( !python_single_target_pypy )"
-
-DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
-
-python_prepare_all() {
- eapply_user
-
- # Replace /var/run with /run, but not in the top source directory
- find . -mindepth 2 -type f -exec \
- sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
-
- sed -i -e 's|runscript|openrc-run|g' files/gentoo-initd || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if python_is_python3; then
- ./fail2ban-2to3 || die
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- "${PYTHON}" "bin/${PN}-testcases" || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run || die
-
- # not FILESDIR
- newconfd files/gentoo-confd ${PN}
- newinitd files/gentoo-initd ${PN}
- sed -e "s:@BINDIR@:${EPREFIX}/usr/bin:g" files/${PN}.service.in > "${T}/${PN}.service" || die
- systemd_dounit "${T}/${PN}.service"
- systemd_dotmpfilesd files/${PN}-tmpfiles.conf
- doman man/*.{1,5}
-
- # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
- # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
- insinto /etc/logrotate.d
- newins files/${PN}-logrotate ${PN}
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.7"
- previous_less_than_0_7=$?
-}
-
-pkg_postinst() {
- if [[ $previous_less_than_0_7 = 0 ]] ; then
- elog
- elog "Configuration files are now in /etc/fail2ban/"
- elog "You probably have to manually update your configuration"
- elog "files before restarting Fail2ban!"
- elog
- elog "Fail2ban is not installed under /usr/lib anymore. The"
- elog "new location is under /usr/share."
- elog
- elog "You are upgrading from version 0.6.x, please see:"
- elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
- fi
-
- if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
- elog "For most jail.conf configurations, it is recommended you install either"
- elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
- elog "to control how log file modifications are detected"
- fi
-
- if ! has_version dev-lang/python[sqlite]; then
- elog "If you want to use ${PN}'s persistent database, then reinstall"
- elog "dev-lang/python with USE=sqlite"
- fi
-
- if has_version sys-apps/systemd[-python]; then
- elog "If you want to track logins through sys-apps/systemd's"
- elog "journal backend, then reinstall sys-apps/systemd with USE=python"
- fi
-}