summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-12-06 13:23:34 -0500
committerRick Farina <zerochaos@gentoo.org>2019-12-06 13:23:46 -0500
commitbd5515cceb69d34d275ceb957ef2cdc3ad133d75 (patch)
treedaaabaa2ccf54768723ea35877904969a624d166 /net-analyzer/gr-fosphor
parentnet-mail/fetchmail: stable 6.4.1 for hppa, bug #701938 (diff)
downloadgentoo-bd5515cceb69d34d275ceb957ef2cdc3ad133d75.tar.gz
gentoo-bd5515cceb69d34d275ceb957ef2cdc3ad133d75.tar.bz2
gentoo-bd5515cceb69d34d275ceb957ef2cdc3ad133d75.zip
net-analyzer/gr-fosphor: qt5 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-analyzer/gr-fosphor')
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index 29c293990ccf..1797e9d1a6a9 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,10 +11,9 @@ HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- SRC_URI=""
#EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
- KEYWORDS=""
+ EGIT_BRANCH="gr37-qt5"
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -24,10 +23,15 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+glfw wxwidgets"
+IUSE="glfw qt5 wxwidgets"
-RDEPEND="
- >=net-wireless/gnuradio-3.7_rc:0=[wxwidgets?,${PYTHON_USEDEP}]
+RDEPEND="qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )
+ >=net-wireless/gnuradio-3.7_rc:0=[qt5,wxwidgets?,${PYTHON_USEDEP}]
media-libs/freetype
dev-libs/boost:=
glfw? ( >=media-libs/glfw-3 )
@@ -52,10 +56,9 @@ src_configure() {
local mycmakeargs=(
-DENABLE_DEFAULT=OFF
-DENABLE_GLFW="$(usex glfw)"
- -DENABLE_QT=OFF
+ -DENABLE_QT="$(usex qt5)"
-DENABLE_WX="$(usex wxwidgets)"
-DENABLE_PYTHON=ON
)
- # re-enable Qt if port to Qt5 is ever finished
cmake-utils_src_configure
}