summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/greenbone-security-assistant/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/greenbone-security-assistant/files')
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-5.0.3-run.patch16
-rwxr-xr-xnet-analyzer/greenbone-security-assistant/files/gsad23
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf14
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.init14
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.logrotate11
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.service16
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.tmpfiles.d1
7 files changed, 95 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-5.0.3-run.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-5.0.3-run.patch
new file mode 100644
index 000000000000..ec5ee92fd73b
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-5.0.3-run.patch
@@ -0,0 +1,16 @@
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 67cf344..c15f785 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -272,7 +272,7 @@ endif (NOT DATADIR)
+
+ set (OPENVAS_STATE_DIR "${LOCALSTATEDIR}/lib/openvas")
+ set (OPENVAS_LOG_DIR "${LOCALSTATEDIR}/log/openvas")
+-set (GSAD_PID_DIR "${LOCALSTATEDIR}/run")
++set (GSAD_PID_DIR "/run")
+ set (GSA_DATA_DIR "${DATADIR}/openvas/gsa")
+
+ # TODO: Eventually use own certificates
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad b/net-analyzer/greenbone-security-assistant/files/gsad
new file mode 100755
index 000000000000..db56dbc89224
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Greenbone Security Assistant Daemon"
+ start-stop-daemon --start --name gsad \
+ --exec /usr/sbin/gsad \
+ --pidfile /var/run/gsad.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stop openvassd"
+ start-stop-daemon --stop --name gsad \
+ --pidfile /var/run/gsad.pid
+ eend $?
+}
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf b/net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf
new file mode 100644
index 000000000000..0de530635122
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf
@@ -0,0 +1,14 @@
+#Listen on given address - by default assistant listens on all addresses
+# ASSISTANT_LISTEN=--listen=127.0.0.1
+
+#Listen on given port - by default 9391
+#ASSISTANT_PORT=--port=9392
+
+#Contact manager on given address
+#MANAGER_LISTEN=--mlisten=127.0.0.1
+
+#Manager listens on given port - by default 9390
+#MANAGER_PORT=--mport=9390
+
+# Additional arguments
+# ASSISTANT_EXTRA_ARGS=""
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.init b/net-analyzer/greenbone-security-assistant/files/gsad.init
new file mode 100644
index 000000000000..27690b2c1782
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.init
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+name="Greenbone Security Assistant Daemon"
+command="/usr/sbin/gsad"
+command_args="${ASSISTANT_LISTEN} ${ASSISTANT_PORT} ${MANAGER_LISTEN} ${MANAGER_PORT} ${ASSISTANT_EXTRA_ARGS}"
+pidfile="/run/gsad.pid"
+
+depend() {
+ after bootmisc
+ need localmount net openvasmd
+}
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.logrotate b/net-analyzer/greenbone-security-assistant/files/gsad.logrotate
new file mode 100644
index 000000000000..f0948cbea1f5
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.logrotate
@@ -0,0 +1,11 @@
+# logrotate for openvas
+/var/log/openvas/gsad.log {
+ rotate 4
+ weekly
+ compress
+ delaycompress
+ missingok
+ postrotate
+ /bin/kill -HUP `pidof gsad`
+ endscript
+}
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.service b/net-analyzer/greenbone-security-assistant/files/gsad.service
new file mode 100644
index 000000000000..8825f52f0949
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Greenbone Security Assistant Daemon
+After=network.target
+Before=openvasmd.service
+
+[Service]
+EnvironmentFile=-/etc/openvas/gsad-daemon.conf
+ExecStart=/usr/sbin/gsad -f ${ASSISTANT_LISTEN} ${ASSISTANT_PORT} ${MANAGER_LISTEN} ${MANAGER_PORT} ${ASSISTANT_EXTRA_ARGS}
+Restart=always
+RestartSec=1
+User=root
+Group=root
+TimeoutSec=1200
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.tmpfiles.d b/net-analyzer/greenbone-security-assistant/files/gsad.tmpfiles.d
new file mode 100644
index 000000000000..18e820caec1b
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.tmpfiles.d
@@ -0,0 +1 @@
+d /var/cache/openvassd 0775