summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-08-12 20:38:49 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-28 06:03:04 +0200
commitb4a09896292f29a452c61a882aab111f2352106c (patch)
tree35b6b0e0e98bf8151ae2c57222f7ef1421d50531 /net-analyzer/greenbone-security-assistant/files
parentprofiles/arch/amd64/x32/package.mask: mask gvm & gsa (diff)
downloadgentoo-b4a09896292f29a452c61a882aab111f2352106c.tar.gz
gentoo-b4a09896292f29a452c61a882aab111f2352106c.tar.bz2
gentoo-b4a09896292f29a452c61a882aab111f2352106c.zip
net-analyzer/greenbone-security-assistant: bump to 8.0.1.
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-analyzer/greenbone-security-assistant/files')
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-cmakelist.patch30
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-node.patch34
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-pid.patch11
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-reactjs.patch20
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-sbin.patch12
-rw-r--r--net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-uninstall-snippet.patch12
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf19
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.init20
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.logrotate13
-rw-r--r--net-analyzer/greenbone-security-assistant/files/gsad.service18
10 files changed, 189 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-cmakelist.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-cmakelist.patch
new file mode 100644
index 000000000000..d0fc7963a501
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-cmakelist.patch
@@ -0,0 +1,30 @@
+--- a/gsad/config/CMakeLists.txt 2019-07-18 20:39:10.331949702 +0300
++++ b/gsad/config/CMakeLists.txt 2019-07-18 20:40:18.946830294 +0300
+@@ -16,27 +16,3 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
+
+-if (NOT SYSTEMD_SERVICE_DIR)
+- set (SYSTEMD_SERVICE_DIR "${CMAKE_INSTALL_PREFIX}/lib/systemd/system")
+-endif (NOT SYSTEMD_SERVICE_DIR)
+-
+-if (NOT DEFAULT_CONFIG_DIR)
+- set (DEFAULT_CONFIG_DIR "${CMAKE_INSTALL_PREFIX}/etc/default")
+-endif (NOT DEFAULT_CONFIG_DIR)
+-
+-if (NOT LOGROTATE_DIR)
+- set (LOGROTATE_DIR "${CMAKE_INSTALL_PREFIX}/etc/logrotate.d")
+-endif (NOT LOGROTATE_DIR)
+-
+-configure_file (gsad.service.in gsad.service)
+-configure_file (gsad.logrotate.in gsad.logrotate)
+-
+-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/gsad.service
+- DESTINATION ${SYSTEMD_SERVICE_DIR}/)
+-
+-install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/gsad.default
+- DESTINATION ${DEFAULT_CONFIG_DIR}/ RENAME gsad)
+-
+-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/gsad.logrotate
+- DESTINATION ${LOGROTATE_DIR}/ RENAME gsad)
+-
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-node.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-node.patch
new file mode 100644
index 000000000000..116bd48264dd
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-node.patch
@@ -0,0 +1,34 @@
+--- a/gsa/CMakeLists.txt 2019-07-17 16:45:39.000000000 +0300
++++ b/gsa/CMakeLists.txt 2019-07-17 22:24:49.466906757 +0300
+@@ -1095,28 +1095,17 @@
+ ${GSA_JS_SRC_FILES}
+ PARENT_SCOPE)
+
+-
+-add_custom_command (OUTPUT node-modules.stamp
+- DEPENDS ${GSA_PKG_FILES}
+- COMMAND ${INSTALLER} "${INSTALLER_ARGS}" "install"
+- COMMAND ${CMAKE_COMMAND} -E touch ${CMAKE_CURRENT_BINARY_DIR}/node-modules.stamp
+- WORKING_DIRECTORY ${GSA_SRC_DIR}
+- COMMENT "Install gsa-ng js dependencies")
+-
+-
+ add_custom_command (OUTPUT bundle.stamp
+- COMMAND ${CMAKE_COMMAND} -E env REACT_APP_VERSION=${PROJECT_VERSION_STRING} ${INSTALLER} "${INSTALLER_ARGS}" run build
++ COMMAND ${CMAKE_COMMAND} -E env REACT_APP_VERSION=${PROJECT_VERSION_STRING} ${INSTALLER} --offline run build
+ COMMAND ${CMAKE_COMMAND} -E touch ${CMAKE_CURRENT_BINARY_DIR}/bundle.stamp
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/node-modules.stamp
+- ${GSA_PKG_FILES}
++ DEPENDS ${GSA_PKG_FILES}
+ ${GSA_STATIC_SRC_FILES}
+ ${GSA_JS_SRC_FILES}
+ COMMENT "Build gsa-ng install files")
+
+ add_custom_target (gsa-ng ALL
+- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/node-modules.stamp
+- ${CMAKE_CURRENT_BINARY_DIR}/bundle.stamp)
++ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/bundle.stamp)
+
+ set (GSA_STATIC_BUILD_FILES
+ ${GSA_BUILD_DIR}/index.html)
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-pid.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-pid.patch
new file mode 100644
index 000000000000..a318c87225e1
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-pid.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -222,7 +222,7 @@ if (NOT DATADIR)
+ endif (NOT DATADIR)
+
+ if (NOT GSAD_PID_DIR)
+- set (GSAD_PID_DIR "${LOCALSTATEDIR}/run")
++ set (GSAD_PID_DIR "/run")
+ endif (NOT GSAD_PID_DIR)
+
+ set (OPENVAS_STATE_DIR "${LOCALSTATEDIR}/lib/openvas")
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-reactjs.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-reactjs.patch
new file mode 100644
index 000000000000..19a4731db75b
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-reactjs.patch
@@ -0,0 +1,20 @@
+--- a/gsa/package.json 2019-07-17 16:45:39.000000000 +0300
++++ b/gsa/package.json 2019-07-17 22:40:31.371899489 +0300
+@@ -66,12 +66,12 @@
+ "x2js": "^3.2.6"
+ },
+ "scripts": {
+- "test": "react-scripts test",
+- "test:coverage": "react-scripts test --coverage --maxWorkers 2",
++ "test": "NODE_ENV=production node_modules/react-scripts/bin/react-scripts.js test",
++ "test:coverage": "NODE_ENV=production node_modules/react-scripts/bin/react-scripts.js test --coverage --maxWorkers 2",
+ "lint": "eslint --max-warnings 0 src",
+- "start": "react-scripts start",
+- "build": "react-scripts build",
+- "eject": "react-scripts eject"
++ "start": "NODE_ENV=production node_modules/react-scripts/bin/react-scripts.js start",
++ "build": "NODE_ENV=production node_modules/react-scripts/bin/react-scripts.js build",
++ "eject": "NODE_ENV=production node_modules/react-scripts/bin/react-scripts.js eject"
+ },
+ "devDependencies": {
+ "@types/jest": "^24.0.12",
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-sbin.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-sbin.patch
new file mode 100644
index 000000000000..c1825ba3f5db
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-sbin.patch
@@ -0,0 +1,12 @@
+--- a/gsad/src/CMakeLists.txt 2019-07-21 23:07:38.375683800 +0300
++++ a/gsad/src/CMakeLists.txt 2019-07-21 23:08:17.301651451 +0300
+@@ -175,7 +175,7 @@
+ ## Install
+
+ install (TARGETS gsad
+- RUNTIME DESTINATION ${SBINDIR}
++ RUNTIME DESTINATION ${BINDIR}
+ LIBRARY DESTINATION ${LIBDIR}
+ ARCHIVE DESTINATION ${LIBDIR}/static)
+
+
diff --git a/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-uninstall-snippet.patch b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-uninstall-snippet.patch
new file mode 100644
index 000000000000..3b075951aba6
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/greenbone-security-assistant-8.0.1-uninstall-snippet.patch
@@ -0,0 +1,12 @@
+--- a/gsa/CMakeLists.txt 2019-07-18 23:14:04.639202986 +0300
++++ b/gsa/CMakeLists.txt 2019-07-18 23:21:54.568052589 +0300
+@@ -1116,9 +1116,6 @@
+ install (FILES public/robots.txt
+ DESTINATION ${GSA_DEST_DIR})
+
+-# remove old generated files
+-install (CODE "file(REMOVE_RECURSE ${GSA_DEST_DIR}/static)")
+-
+ install (DIRECTORY
+ ${GSA_BUILD_DIR}/static
+ ${GSA_BUILD_DIR}/img
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf b/net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf
new file mode 100644
index 000000000000..f7c7ee514e50
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad-daemon.conf
@@ -0,0 +1,19 @@
+# Greenbone Security Assistant command args
+
+# e.g. --foreground | e.g. --no-redirect
+GSAD_OPTIONS="--no-redirect"
+
+# GSAD listen adress
+GSAD_LISTEN_ADDRESS="--listen=127.0.0.1"
+
+# GSAD listen port
+GSAD_LISTEN_PORT="--port=9392"
+
+# GVMD listen address
+GVMD_LISTEN_ADDRESS="--mlisten=127.0.0.1"
+
+# GVMD listen port
+GVMD_LISTEN_PORT="--mport=9390"
+
+# TLS Settings
+GSAD_GNUTLS_PRIORITIES="--gnutls-priorities=NORMAL"
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.init b/net-analyzer/greenbone-security-assistant/files/gsad.init
new file mode 100644
index 000000000000..6d431bd21196
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.init
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+: ${GSAD_USER:=gvm}
+: ${GSAD_GROUP:=gvm}
+: ${GSAD_TIMEOUT:=30}
+
+name="Greenbone Security Assistant (GSA)"
+command="/usr/bin/gsad"
+command_args="${GSAD_OPTIONS} ${GSAD_LISTEN_ADDRESS} ${GSAD_LISTEN_PORT} ${GVMD_LISTEN_ADDRESS} ${GVMD_LISTEN_PORT} ${GSAD_GNUTLS_PRIORITIES}"
+command_background="true"
+command_user="${GSAD_USER}:${GSAD_GROUP}"
+pidfile="/run/gsad.pid"
+retry="${GSAD_TIMEOUT}"
+
+depend() {
+ after bootmisc
+ need localmount net gvmd
+}
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.logrotate b/net-analyzer/greenbone-security-assistant/files/gsad.logrotate
new file mode 100644
index 000000000000..f80bba881c7b
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.logrotate
@@ -0,0 +1,13 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+# Daemon ignore HUP so we use 'copytruncate' instead of 'create'
+# with safe file size to prevent losing log entries.
+
+/var/log/gvm/gsad.log {
+ compress
+ missingok
+ notifempty
+ sharedscripts
+ copytruncate
+ maxsize 10M
+}
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad.service b/net-analyzer/greenbone-security-assistant/files/gsad.service
new file mode 100644
index 000000000000..91e791878008
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Greenbone Security Assistant
+After=network.target
+After=openvassd.service
+After=gvmd.service
+Wants=gvmd.service
+
+[Service]
+Type=forking
+User=gvm
+Group=gvm
+EnvironmentFile=-/etc/gvm/sysconfig/gsad-daemon.conf
+ExecStart=/usr/bin/gsad $GSAD_OPTIONS $GSAD_LISTEN_ADDRESS $GSAD_LISTEN_PORT $GVMD_LISTEN_ADDRESS $GVMD_LISTEN_PORT $GSAD_GNUTLS_PRIORITIES
+Restart=always
+RestartSec=10
+
+[Install]
+WantedBy=multi-user.target