summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2023-10-08 09:05:37 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-09 12:54:10 +0200
commita5dcfd414cf53fe80df074b7cc2930bbc60e7398 (patch)
tree23415040475ba751d03e9fcfa982c1de07899783 /net-analyzer/gsad
parentnet-analyzer/gvm: fix openrc init script (diff)
downloadgentoo-a5dcfd414cf53fe80df074b7cc2930bbc60e7398.tar.gz
gentoo-a5dcfd414cf53fe80df074b7cc2930bbc60e7398.tar.bz2
gentoo-a5dcfd414cf53fe80df074b7cc2930bbc60e7398.zip
net-analyzer/gsad: fix OpenRC init script
On first run the log file was created by root and was unwritable to gvm Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33243 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/gsad')
-rw-r--r--net-analyzer/gsad/files/gsad-22.init6
-rw-r--r--net-analyzer/gsad/gsad-22.6.0-r1.ebuild (renamed from net-analyzer/gsad/gsad-22.6.0.ebuild)0
2 files changed, 5 insertions, 1 deletions
diff --git a/net-analyzer/gsad/files/gsad-22.init b/net-analyzer/gsad/files/gsad-22.init
index aae78b2e1ab8..a17f2dc1c084 100644
--- a/net-analyzer/gsad/files/gsad-22.init
+++ b/net-analyzer/gsad/files/gsad-22.init
@@ -3,6 +3,7 @@
# Distributed under the terms of the GNU General Public License v2
: ${GSAD_USER:=gvm}
+: ${GSAD_GROUP:=gvm}
: ${GSAD_TIMEOUT:=30}
: ${GSAD_PIDFILE:="/run/gsad/gsad.pid"}
@@ -21,6 +22,10 @@ start_pre() {
checkpath -d --mode 0755 --owner root /run/gsad
}
+start_post() {
+ checkpath -f --mode 0644 --owner "${GSAD_USER}:${GSAD_GROUP}" /var/log/gvm/gsad.log
+}
+
stop_post() {
if [ -f "${GSAD_PIDFILE}" ]; then
ebegin "Removing PID file"
@@ -28,4 +33,3 @@ stop_post() {
eend $?
fi
}
-
diff --git a/net-analyzer/gsad/gsad-22.6.0.ebuild b/net-analyzer/gsad/gsad-22.6.0-r1.ebuild
index f8fe3475bfda..f8fe3475bfda 100644
--- a/net-analyzer/gsad/gsad-22.6.0.ebuild
+++ b/net-analyzer/gsad/gsad-22.6.0-r1.ebuild