summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-16 22:48:45 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-16 22:49:10 +0200
commit3b38108bc45b4930319a10e22f7c576dbc92a566 (patch)
tree669fe5529695e3436494f1a4fde679b77122e4ee /net-analyzer/hydra
parentkde-apps/libkcompactdisc: Drop 16.12.3 (r0) (diff)
downloadgentoo-3b38108bc45b4930319a10e22f7c576dbc92a566.tar.gz
gentoo-3b38108bc45b4930319a10e22f7c576dbc92a566.tar.bz2
gentoo-3b38108bc45b4930319a10e22f7c576dbc92a566.zip
net-analyzer/hydra: Version bump (bug #615584).
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-analyzer/hydra')
-rw-r--r--net-analyzer/hydra/Manifest1
-rw-r--r--net-analyzer/hydra/files/hydra-8.4-configure.patch48
-rw-r--r--net-analyzer/hydra/hydra-8.4.ebuild101
3 files changed, 150 insertions, 0 deletions
diff --git a/net-analyzer/hydra/Manifest b/net-analyzer/hydra/Manifest
index 63141477f5b6..01de2f14ba9a 100644
--- a/net-analyzer/hydra/Manifest
+++ b/net-analyzer/hydra/Manifest
@@ -1 +1,2 @@
DIST hydra-8.1.tar.gz 559031 SHA256 e4bc2fd11f97a8d985a38a31785c86d38cc60383e47a8f4a5c436351e5135f19 SHA512 7608dd365865e5976bea446faedaad9f0334e7572fd0ee47a601c471471fc7c8a922c7114f4df08705b34b29144d3a6552e66148adf6b0f92c67301119c94959 WHIRLPOOL b1555fe1a8257c88f8f5c110fce1d06834eb6dadad394b61e2a90c3289b8fdd117944da160871003b1583aefb81a02d5c49a653e8de7d3adcd07917ae760c83c
+DIST hydra-8.4.tar.gz 1205609 SHA256 482846580888f54e000bb125e263a65c32fa28ba86c9d4012371cf55c3bdc140 SHA512 62c53f1725eb5b965d16d293cd90ab5e74779eba8fe2e2ab9094f51851fa24acfd74574f509a7914af8254e43197d803cca6b41eace3557d9599d79d695f6a48 WHIRLPOOL aecc31645e7775662e32b766baa942e92e31143e5b6fbe64620ee85179288dc60f3ada477b4605444769c9e76c17d94835db5f3651af409d5562a2e8971279ef
diff --git a/net-analyzer/hydra/files/hydra-8.4-configure.patch b/net-analyzer/hydra/files/hydra-8.4-configure.patch
new file mode 100644
index 000000000000..ba99ff2acda4
--- /dev/null
+++ b/net-analyzer/hydra/files/hydra-8.4-configure.patch
@@ -0,0 +1,48 @@
+--- a/configure
++++ b/configure
+@@ -46,8 +46,6 @@
+ MYSQL_IPATH=""
+ AFP_PATH=""
+ AFP_IPATH=""
+-NCP_PATH=""
+-NCP_IPATH=""
+ SVN_PATH=""
+ SVN_IPATH=""
+ APR_IPATH=""
+@@ -679,36 +677,6 @@
+ fi
+
+ echo "Checking for NCP (libncp.so / nwcalls.h) ..."
+-for i in $LIBDIRS ; do
+- if [ "X" = "X$NCP_PATH" ]; then
+- if [ -f "$i/libncp.so" -o -f "$i/libncp.dylib" -o -f "$i/libncp.a" ]; then
+- NCP_PATH="$i"
+- fi
+- fi
+- if [ "X" = "X$NCP_PATH" ]; then
+- TMP_LIB=`/bin/ls $i/libncp.so.* 2> /dev/null | grep ncp.`
+- if [ -n "$TMP_LIB" ]; then
+- NCP_PATH="$i"
+- fi
+- fi
+- if [ "X" = "X$NCP_PATH" ]; then
+- TMP_LIB=`/bin/ls $i/libncp.dll* 2> /dev/null | grep ncp.`
+- if [ -n "$TMP_LIB" ]; then
+- NCP_PATH="$i"
+- fi
+- fi
+-done
+-for i in $INCDIRS ; do
+- if [ "X" != "X$NCP_PATH" ]; then
+- if [ -f "$i/ncp/nwcalls.h" ]; then
+- NCP_IPATH="$i"
+- fi
+- fi
+-done
+-if [ "X" != "X$DEBUG" ]; then
+- echo DEBUG: NCP_PATH=$NCP_PATH/libncp
+- echo DEBUG: NCP_IPATH=$NCP_IPATH/ncp/nwcalls.h
+-fi
+ if [ -n "$NCP_PATH" -a -n "$NCP_IPATH" ]; then
+ echo " ... found"
+ fi
diff --git a/net-analyzer/hydra/hydra-8.4.ebuild b/net-analyzer/hydra/hydra-8.4.ebuild
new file mode 100644
index 000000000000..ce796181b202
--- /dev/null
+++ b/net-analyzer/hydra/hydra-8.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Advanced parallized login hacker"
+HOMEPAGE="https://www.thc.org/thc-hydra/"
+SRC_URI="https://www.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="firebird gtk idn libressl mysql ncp oracle pcre postgres ssl subversion"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/ncurses:=
+ firebird? ( dev-db/firebird )
+ gtk? (
+ dev-libs/atk
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+ idn? ( net-dns/libidn )
+ mysql? ( virtual/mysql )
+ ncp? ( net-fs/ncpfs )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql:* )
+ ssl? ( >=net-libs/libssh-0.4.0 )
+ subversion? ( dev-vcs/subversion )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.4-configure.patch
+)
+
+src_prepare() {
+ default
+ # None of the settings in Makefile.unix are useful to us
+ : > Makefile.unix
+
+ sed -i \
+ -e 's:|| echo.*$::' \
+ -e '/\t-$(CC)/s:-::' \
+ -e '/^OPTS/{s|=|+=|;s| -O3||}' \
+ -e '/ -o /s:$(OPTS):& $(LDFLAGS):g' \
+ Makefile.am || die
+}
+
+src_configure() {
+ export OPTS="${CFLAGS}"
+
+ if ! use subversion; then
+ sed -i 's/-lsvn_client-1 -lapr-1 -laprutil-1 -lsvn_subr-1//;s/-DLIBSVN//' configure || die
+ fi
+
+ if ! use mysql; then
+ sed -i 's/-lmysqlclient//;s/-DLIBMYSQLCLIENT//' configure || die
+ fi
+
+ # Linking against libtinfo might be enough here but pkg-config --libs tinfo
+ # would require a USE=tinfo flag and recent linkers should drop libcurses
+ # as needed
+ sed -i \
+ -e 's|-lcurses|'"$( $(tc-getPKG_CONFIG) --libs ncurses)"'|g' \
+ configure || die
+
+ # Note: despite the naming convention, the top level script is not an
+ # autoconf-based script.
+ export NCP_PATH=$(usex ncp /usr/$(get_libdir) '')
+ export NCP_IPATH=$(usex ncp /usr/include '')
+ sh configure \
+ --prefix=/usr \
+ --nostrip \
+ $(use gtk && echo --disable-xhydra) \
+ || die
+
+ if use gtk ; then
+ cd hydra-gtk && \
+ econf
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake XLIBPATHS=''
+ use gtk && emake -C hydra-gtk
+}
+
+src_install() {
+ dobin hydra pw-inspector
+ use gtk && dobin hydra-gtk/src/xhydra
+ dodoc CHANGES README
+}