summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-09-22 01:05:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-09-22 01:07:52 -0500
commit88f20115574f83da8068a36059f6a30e7244c657 (patch)
tree2916c06eebdc951a43c78f5af95476a27ecdeb4c /net-analyzer/icinga2
parentdev-ruby/rspec-collection_matchers: add 1.2.0 (diff)
downloadgentoo-88f20115574f83da8068a36059f6a30e7244c657.tar.gz
gentoo-88f20115574f83da8068a36059f6a30e7244c657.tar.bz2
gentoo-88f20115574f83da8068a36059f6a30e7244c657.zip
net-analyzer/icinga2: update boost dep to depend on context flag
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'net-analyzer/icinga2')
-rw-r--r--net-analyzer/icinga2/icinga2-2.11.0.ebuild5
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild2
2 files changed, 4 insertions, 3 deletions
diff --git a/net-analyzer/icinga2/icinga2-2.11.0.ebuild b/net-analyzer/icinga2/icinga2-2.11.0.ebuild
index 3ec54860fd1f..238cca62c36f 100644
--- a/net-analyzer/icinga2/icinga2-2.11.0.ebuild
+++ b/net-analyzer/icinga2/icinga2-2.11.0.ebuild
@@ -5,7 +5,7 @@ EAPI=6
if [[ ${PV} != 9999 ]]; then
inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
else
inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
@@ -23,7 +23,8 @@ WX_GTK_VER="3.0"
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.66:=
+ >=dev-libs/boost-1.66.0:=[context]
+ <dev-libs/boost-1.71.0
console? ( dev-libs/libedit )
mariadb? ( dev-db/mariadb-connector-c:= )
mysql? ( dev-db/mysql-connector-c:= )
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index 3ec54860fd1f..31e997e9e6a5 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -23,7 +23,7 @@ WX_GTK_VER="3.0"
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.66:=
+ >=dev-libs/boost-1.66:=[context]
console? ( dev-libs/libedit )
mariadb? ( dev-db/mariadb-connector-c:= )
mysql? ( dev-db/mysql-connector-c:= )