summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-17 10:56:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-17 11:02:12 -0500
commit8b834fa574a2595f283a10129173bc297c86b6fa (patch)
tree4671bae30e48875d597aa6118d639415781168ad /net-analyzer/icinga2
parentnet-wireless/gnuradio: bump (diff)
downloadgentoo-8b834fa574a2595f283a10129173bc297c86b6fa.tar.gz
gentoo-8b834fa574a2595f283a10129173bc297c86b6fa.tar.bz2
gentoo-8b834fa574a2595f283a10129173bc297c86b6fa.zip
net-analyzer/icinga2: 2.9.0 bup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-analyzer/icinga2')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.9.0.ebuild163
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild21
3 files changed, 168 insertions, 17 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index a04866da9ea5..4ab458d6d224 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1 +1,2 @@
DIST icinga2-2.8.4.tar.gz 2510333 BLAKE2B f551a5eadc93d8455612af40e34a0922bc75f41b8064f9989c8f0c28dc2c3fb18963cf9b3272efa29f03973e7cf5824762bebff1bfa1a23c4ba39c93fc29c8e5 SHA512 b2cb5989962ac65da927cbdbac1b3345c913321d507b5113f32dd90bf969b2513478e68d52b9cd4cf255057d74428f9e42067288b7ddc59ad060ca7b84f4f114
+DIST icinga2-2.9.0.tar.gz 2192684 BLAKE2B b27da06a8b1d70108c792ccbef67a8082b7bb1ec9326ffdcd56406e8bf00e00fa7ef7cbedae803835cc7576bfb1db07cac4e6d1c8338d67e0ff071b821a661ea SHA512 e95f29f9a7e2ba9ad2ca16972fad23a9d18ee0470fbfd70f0bbc8efba9cdcce77d7c5abd2fca98e7b30c64f0014f89f9edd494473769efa6a6e01c08ebdcc1a4
diff --git a/net-analyzer/icinga2/icinga2-2.9.0.ebuild b/net-analyzer/icinga2/icinga2-2.9.0.ebuild
new file mode 100644
index 000000000000..3085070c612b
--- /dev/null
+++ b/net-analyzer/icinga2/icinga2-2.9.0.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+if [[ ${PV} != 9999 ]]; then
+ inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
+ SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+else
+ inherit cmake-utils depend.apache eutils git-r3 systemd toolchain-funcs user wxwidgets
+ EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Distributed, general purpose, network monitoring engine"
+HOMEPAGE="http://icinga.org/icinga2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins systemd +vim-syntax"
+WX_GTK_VER="3.0"
+
+CDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ >=dev-libs/boost-1.58-r1
+ console? ( dev-libs/libedit )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )"
+
+DEPEND="
+ ${CDEPEND}
+ sys-devel/bison
+ >=sys-devel/flex-2.5.35"
+
+RDEPEND="
+ ${CDEPEND}
+ plugins? ( || (
+ net-analyzer/monitoring-plugins
+ net-analyzer/nagios-plugins
+ ) )
+ mail? ( virtual/mailx )
+ classicui? ( net-analyzer/icinga[web] )"
+
+REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+ enewgroup icinga
+ enewgroup icingacmd
+ enewgroup nagios # for plugins
+ enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
+}
+
+src_configure() {
+ sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
+ local mycmakeargs=(
+ -DICINGA2_UNITY_BUILD=FALSE
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var
+ -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+ -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
+ -DICINGA2_USER=icinga
+ -DICINGA2_GROUP=icingacmd
+ -DICINGA2_COMMAND_GROUP=icingacmd
+ -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ -DUSE_SYSTEMD=$(usex systemd ON OFF)
+ -DLOGROTATE_HAS_SU=ON
+ )
+ # default to off if minimal, allow the flags to be set otherwise
+ if use minimal; then
+ mycmakeargs+=(
+ -DICINGA2_WITH_MYSQL=OFF
+ -DICINGA2_WITH_PGSQL=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
+ -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
+ )
+ fi
+ # LTO
+ if use lto; then
+ mycmakeargs+=(
+ -DICINGA2_LTO_BUILD=ON
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_LTO_BUILD=OFF
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
+ cd "${BUILDDIR}" || die
+
+ emake DESTDIR="${D}" install
+
+ einstalldocs
+
+ newinitd "${FILESDIR}"/icinga2.initd icinga2
+
+ if use mysql ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
+ elif use postgres ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
+ fi
+
+ keepdir /etc/icinga2
+ keepdir /var/lib/icinga2/api/zones
+ keepdir /var/lib/icinga2/api/repository
+ keepdir /var/lib/icinga2/api/log
+ keepdir /var/spool/icinga2/perfdata
+
+ rm -r "${D}/var/run" || die "failed to remove /var/run"
+ rm -r "${D}/var/cache" || die "failed to remove /var/cache"
+
+ fowners root:icinga /etc/icinga2
+ fperms 0750 /etc/icinga2
+ fowners icinga:icinga /var/lib/icinga2
+ fowners icinga:icinga /var/spool/icinga2
+ fowners -R icinga:icingacmd /var/lib/icinga2/api
+ fowners icinga:icinga /var/spool/icinga2/perfdata
+ fowners icinga:icingacmd /var/log/icinga2
+
+ fperms ug+rwX,o-rwx /etc/icinga2
+ fperms ug+rwX,o-rwx /var/lib/icinga2
+ fperms ug+rwX,o-rwx /var/spool/icinga2
+ fperms ug+rwX,o-rwx /var/log/icinga2
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
+ fi
+
+ if use nano-syntax; then
+ insinto /usr/share/nano
+ doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then
+ elog "DB IDO schema upgrade may be required required.
+ http://docs.icinga.org/icinga2/snapshot/doc/module/icinga2/chapter/upgrading-icinga-2"
+ fi
+}
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index ebdd790be879..3085070c612b 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ HOMEPAGE="http://icinga.org/icinga2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
+IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins systemd +vim-syntax"
WX_GTK_VER="3.0"
CDEPEND="
@@ -41,8 +41,7 @@ RDEPEND="
net-analyzer/nagios-plugins
) )
mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:3.0 )"
+ classicui? ( net-analyzer/icinga[web] )"
REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
@@ -50,9 +49,6 @@ want_apache2
pkg_setup() {
depend.apache_pkg_setup
- if use studio ; then
- setup-wxwidgets
- fi
enewgroup icinga
enewgroup icingacmd
enewgroup nagios # for plugins
@@ -74,6 +70,7 @@ src_configure() {
-DICINGA2_GROUP=icingacmd
-DICINGA2_COMMAND_GROUP=icingacmd
-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ -DUSE_SYSTEMD=$(usex systemd ON OFF)
-DLOGROTATE_HAS_SU=ON
)
# default to off if minimal, allow the flags to be set otherwise
@@ -98,16 +95,6 @@ src_configure() {
-DICINGA2_LTO_BUILD=OFF
)
fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
cmake-utils_src_configure
}