summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/jffnms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/jffnms')
-rw-r--r--net-analyzer/jffnms/Manifest1
-rw-r--r--net-analyzer/jffnms/jffnms-0.9.4.ebuild58
-rw-r--r--net-analyzer/jffnms/metadata.xml8
3 files changed, 67 insertions, 0 deletions
diff --git a/net-analyzer/jffnms/Manifest b/net-analyzer/jffnms/Manifest
new file mode 100644
index 000000000000..8c364f7656ce
--- /dev/null
+++ b/net-analyzer/jffnms/Manifest
@@ -0,0 +1 @@
+DIST jffnms-0.9.4.tgz 610758 SHA256 8e20d361ad3dc01d800315e3978f1873c3b6d1ebd3bc93a74a3fb8789d56da2b SHA512 4d0c4ed1fbf0107029d92b2ea8f0f02c46d532810dc58bf048c5ffaf79f7f24630101be8319876db1aee3356ced32e7cba2f2494bc8a92a635b0a4e6897c6fe7 WHIRLPOOL 10ac59bd5a52c1803e124b6a47b889bda938760359bd995311486c7156840ddd88092ceba5280fb090dd3484927f6d52121428e4a75d4aca1cb6135ee8cf29e2
diff --git a/net-analyzer/jffnms/jffnms-0.9.4.ebuild b/net-analyzer/jffnms/jffnms-0.9.4.ebuild
new file mode 100644
index 000000000000..ed2b1962b859
--- /dev/null
+++ b/net-analyzer/jffnms/jffnms-0.9.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit user
+
+DESCRIPTION="Network Management and Monitoring System"
+HOMEPAGE="http://www.jffnms.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres snmp"
+
+RDEPEND="
+ app-mobilephone/smsclient
+ dev-lang/php[apache2,cli,gd,mysql?,postgres?,session,snmp,sockets,wddx]
+ dev-php/PEAR-PEAR
+ media-gfx/graphviz
+ media-libs/gd
+ net-analyzer/fping
+ net-analyzer/net-snmp
+ net-analyzer/nmap
+ net-analyzer/rrdtool[graph]
+ sys-apps/diffutils
+"
+
+pkg_setup() {
+ enewgroup jffnms
+ enewuser jffnms -1 /bin/bash -1 jffnms,apache
+}
+
+src_install(){
+ local INSTALL_DIR="/opt/${PN}"
+ local IMAGE_DIR="${D}${INSTALL_DIR}"
+
+ insinto "${INSTALL_DIR}"
+ doins -r *
+
+ rm -f "${IMAGE_DIR}/LICENSE"
+
+ # Clean up Windows related stuff
+ rm -f "${IMAGE_DIR}"/*.win32.txt
+ rm -rf "${IMAGE_DIR}"/docs/windows
+ rm -rf "${IMAGE_DIR}"/engine/windows
+
+ fowners -R jffnms:apache "${INSTALL_DIR}"
+ fperms -R ug+rw "${INSTALL_DIR}"
+}
+
+pkg_postinst() {
+ elog "${PN} has been partialy installed on your system. However you"
+ elog "still need proceed with final installation and configuration."
+ elog "You can visit https://wiki.gentoo.org/wiki/Jffnms in order"
+ elog "to get detailed information on how to get jffnms up and running."
+}
diff --git a/net-analyzer/jffnms/metadata.xml b/net-analyzer/jffnms/metadata.xml
new file mode 100644
index 000000000000..c174f0301efe
--- /dev/null
+++ b/net-analyzer/jffnms/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">jffnms</remote-id>
+ </upstream>
+</pkgmetadata>