summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2019-01-18 13:36:36 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-19 04:21:46 +0100
commit8a1c5928df2db8e0e321bfda31c38b49c21f7a35 (patch)
treed1e121dbc59fb871fee5d9661fbd909b65b621d8 /net-analyzer/linkchecker
parentnet-analyzer/linkchecker: bump to 9.4.0 (diff)
downloadgentoo-8a1c5928df2db8e0e321bfda31c38b49c21f7a35.tar.gz
gentoo-8a1c5928df2db8e0e321bfda31c38b49c21f7a35.tar.bz2
gentoo-8a1c5928df2db8e0e321bfda31c38b49c21f7a35.zip
net-analyzer/linkchecker: sync live ebuild
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10860 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
index 81a23e9d21b6..528d4f9fc6cc 100644
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite?"
@@ -16,29 +16,31 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gnome sqlite"
+IUSE="sqlite"
RDEPEND="
dev-python/pyxdg[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}]
virtual/python-dnspython[${PYTHON_USEDEP}]
- gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
"
DEPEND=""
RESTRICT="test"
python_prepare_all() {
- local PATCHES=( "${FILESDIR}"/${PN}-9.3-bash-completion.patch )
+ local PATCHES=(
+ "${FILESDIR}/${PN}-9.3-bash-completion.patch"
+ )
distutils-r1_python_prepare_all
}
python_install_all() {
DOCS=(
- doc/upgrading.txt
- doc/python3.txt
doc/changelog.txt
doc/development.mdwn
+ doc/python3.txt
+ doc/upgrading.txt
)
distutils-r1_python_install_all